Opened 7 years ago

Closed 7 years ago

#11028 closed Bug Report - General (Won't Fix)

Audio output remains Dolby Digital when channels shift from 5.1ch to 2ch

Reported by: rparrish@… Owned by: JYA
Priority: minor Milestone: unknown
Component: MythTV - Audio Output Version: 0.25-fixes
Severity: medium Keywords: ac-3 stereo 5.1
Cc: Ticket locked: no

Description

Mythfrontend is configured with speaker count set to 5.1, AC-3 passthrough enabled, and upmixing disabled.

When watching a recording which begins with DD Stereo audio, output is PCM Stereo as expected. If the audio track changes to DD5.1, output changes to DD5.1 -- also as expected. But when the audio track changes back to DD Stereo, the output switches to DD Stereo instead of PCM Stereo. I have verified this behavior using the indicators on my audio/video receiver.

I have hosted a test clip which can be used to demonstrate this behavior at this link: http://sdrv.ms/SYrb8a (Link points to file on my Microsoft Sky Drive account)

I am using Mythbuntu's 0.25-fixes repo on Ubuntu Lucid.

Mythfrontend Version info: MythTV Version : v0.25.2-15-g46cab93 MythTV Branch : fixes/0.25 Network Protocol : 72 Library API : 0.25.20120506-1 QT Version : 4.6.2 Options compiled in:

linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv using_ivtv using_joystick_menu using_libcec using_libcrypto using_libdns_sd using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_v4l1 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg using_libxml2

Change History (1)

comment:1 Changed 7 years ago by JYA

Resolution: Won't Fix
Status: newclosed

Works as intended.

You don't want to change mid-ways unless absolutely necessary otherwise you get a pause in the audio which can take several seconds depending on the amplifier and how long it takes for them to sync.

Audio will be decoded from DD only if absolutely required, like you activate timestretch

Note: See TracTickets for help on using tickets.