Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 20 months ago

Closed 20 months ago

#11029 closed Bug Report - Crash (fixed)

mythfrontend crash on starting playback

Reported by: Stephen Robertson <stephengrobertson@…> Owned by: stichnot
Priority: blocker Milestone: 0.26
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The frontend crashes consistently on trying to playback certain recordings but only if they are not the first recording played back after mythfrontend is started. I think I am correct in saying that all my recordings will playback if they are the first to be played.

I have not established what is special about the ones that it crashes on. In my experimentation I have been using two recordings of the same show, on the same channel, using the same card, that were recorded 24 hours apart. One shows this problem and one doesn't These are HD recordings from Freesat in the UK. The problem is not specific to this though I get the same symptom on some recordings from an SD broadcast from DVB-T.

Attachments (7)

gdb.txt (110.8 KB) - added by Stephen Robertson <stephengrobertson@…> 20 months ago.
gdb output
version.txt (880 bytes) - added by Stephen Robertson <stephengrobertson@…> 20 months ago.
mythavtest-fail.txt (10.9 KB) - added by douglas.mackay@… 20 months ago.
mythavtest --loglevel debug -v general,playback,libav (crashed)
mythavtest-good.txt (30.9 KB) - added by douglas.mackay@… 20 months ago.
mythavtest --loglevel debug -v general,playback,libav (played)
valgrind.log.tar.gz (98.7 KB) - added by douglas.mackay@… 20 months ago.
valgrind log
valgrind.log-proper.tar.gz (488.0 KB) - added by douglas.mackay@… 20 months ago.
proper valgrind log - ignore previous
valgrind-combined.log.tar.gz (492.7 KB) - added by douglas.mackay@… 20 months ago.
valgrind & mythavtest combined log

Download all attachments as: .zip

Change History (13)

Changed 20 months ago by Stephen Robertson <stephengrobertson@…>

gdb output

Changed 20 months ago by Stephen Robertson <stephengrobertson@…>

comment:1 Changed 20 months ago by douglas.mackay@…

My crash reports for the same issue (one from a remote frontend and the other from the backend) are :-
https://bugs.launchpad.net/mythbuntu/+bug/1041788
https://bugs.launchpad.net/mythbuntu/+bug/1041797

Further testing has shown that the crash is intermittent when mythpreviewgen is generating the preview. It only seems to affect BBC channels (SD, HD on both UK Freeview and UK Freesat)

Manually running mythpreviewgen on an affected recording can cause the crash about 50% of the time.

Sample (6MB) - http://www.filedropper.com/100120120826105500

comment:2 Changed 20 months ago by stuartm

  • Milestone changed from unknown to 0.26
  • Priority changed from minor to blocker
  • Type changed from Bug Report - General to Bug Report - Crash
  • Version changed from Unspecified to Master Head

Changed 20 months ago by douglas.mackay@…

mythavtest --loglevel debug -v general,playback,libav (crashed)

Changed 20 months ago by douglas.mackay@…

mythavtest --loglevel debug -v general,playback,libav (played)

comment:3 Changed 20 months ago by douglas.mackay@…

I've attached two logs (one a crash the other played back ok) from mythavtest --loglevel debug -v general,playback,libav using the above sample.

It's seems to be hit or miss if it plays back. It can play back times then crash on the next attempt.

Changed 20 months ago by douglas.mackay@…

valgrind log

Changed 20 months ago by douglas.mackay@…

proper valgrind log - ignore previous

Changed 20 months ago by douglas.mackay@…

valgrind & mythavtest combined log

comment:4 Changed 20 months ago by Stephen Robertson <stephengrobertson@…>

So far I am unable to reproduce this problem when building v0.26-rc-23-gb5fbc74 (with or without patch http://pastebin.com/7Pj1Kjke) locally but the problem is still very repeatable when same the version is installed via mythbuntu packages (Original report was from using mythbuntu packages)

comment:5 Changed 20 months ago by stichnot

  • Component changed from MythTV - General to MythTV - Video Playback
  • Owner set to stichnot
  • Status changed from new to accepted

comment:6 Changed 20 months ago by Jim Stichnoth <jstichnoth@…>

  • Resolution set to fixed
  • Status changed from accepted to closed

In 92016b94983a4b8a6cb75dbc48893f5c05ce4620/mythtv:

Fixes #11029. Ensure AVPacket's data and size fields are initialized.

Without this initialization, mpegts_push_section() may try to access
uninitialized data and size fields from the AVPacket structure.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.