Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#11031 closed Bug Report - General (Won't Fix)

Widgets display incorrect info when used with depends switch

Reported by: ylee@… Owned by: stuartm
Priority: minor Milestone: unknown
Component: MythTV - User Interface Library Version: 0.25-fixes
Severity: medium Keywords: mythui depends widget
Cc: Ticket locked: yes

Description

I am working on modifying the Mythbuntu theme's Watch Recordings page to display widgets such as title, subtitle, and description in varying ways depending on whether cover art is available. In doing so I believe I have found a bug with the "depends" switch.

To see it in action, drop the attached into the Mythbuntu theme directory, switch to the theme, and go to Watch Recordings. Traverse the left and right panes. Note how the widgets on the bottom of the screen don't get updated correctly, typically after going between entries with cover art and those without. Sometimes the displayed text changes after a few seconds, as if caching of expired data is occurring. (Could the speedups in #10161 be responsible?)

Attachments (1)

recordings-ui.xml (30.0 KB) - added by ylee@… 7 years ago.
Demonstration of bug. Put into Mythbuntu directory and go to Watch Recordings.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by ylee@…

Attachment: recordings-ui.xml added

Demonstration of bug. Put into Mythbuntu directory and go to Watch Recordings.

comment:1 Changed 7 years ago by Yeechang Lee <ylee@…>

Clarification: I am running stock 0.25, which I had thought #10161 had been incorporated into. It cannot be responsible.

comment:2 Changed 7 years ago by stuartm

Resolution: Won't Fix
Status: newclosed

This is not a bug exactly, it's just the way mythui was designed from the beginning, each named widget can only be included once in a screen, so having two groups containing the same widgets just won't work. Changing this is complicated since it's at the core of the design.

I'm closing this for now, it's more of a feature request.

comment:3 Changed 6 years ago by stuartm

Ticket locked: set

Still not a bug

Note: See TracTickets for help on using tickets.