Opened 7 years ago

Closed 5 years ago

#11056 closed Bug Report - Crash (Invalid)

after install MythWeb on ubuntu server, password gen failed, web not working

Reported by: spam@… Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

datetime: 2012-08-29 09:39:29 (CEST) errornum: 256

error type: User Error

error string: !NoTrans: Access denied for user 'mythtv'@'localhost' (using password: YES) #1045

Backtrace Array (

[0] => Array

(

[file] => /usr/share/mythtv/mythweb/classes/Database/Query/mysql.php [line] => 63 [function] => error [class] => Database [object] => Database_mysql Object

(

[dbh] => [error] => Access denied for user 'mythtv'@'localhost' (using password: YES) #1045 [err] => Access denied for user 'mythtv'@'localhost' (using password: YES) [errno] => 1045 [last_sh] => Database_Query_mysql Object

(

[dbh] => [query] => Array

(

[0] => SET NAMES utf8;

)

[last_query] => SET NAMES utf8; [warnings] => Array ( ) [num_args_needed] => 0 [num_rows] => [affected_rows] => [insert_id] => [db] => Database_mysql Object

*RECURSION*

)

[fatal_errors] => 1 [query_count] => 0 [query_time] => 0 [global_name] => [destruct_handlers] => Array ( )

)

[type] => -> [args] => Array ( )

)

[1] => Array

(

[file] => /usr/share/mythtv/mythweb/classes/Database.php [line] => 259 [function] => execute [class] => Database_Query_mysql [object] => Database_Query_mysql Object

(

[dbh] => [query] => Array

(

[0] => SET NAMES utf8;

)

[last_query] => SET NAMES utf8; [warnings] => Array ( ) [num_args_needed] => 0 [num_rows] => [affected_rows] => [insert_id] => [db] => Database_mysql Object

(

[dbh] => [error] => Access denied for user 'mythtv'@'localhost' (using password: YES) #1045 [err] => Access denied for user 'mythtv'@'localhost' (using password: YES) [errno] => 1045 [last_sh] => Database_Query_mysql Object

*RECURSION*

[fatal_errors] => 1 [query_count] => 0 [query_time] => 0 [global_name] => [destruct_handlers] => Array ( )

)

)

[type] => -> [args] => Array

(

[0] => Array ( )

)

)

[2] => Array

(

[file] => /usr/share/mythtv/mythweb/classes/Database.php [line] => 124 [function] => query [class] => Database [object] => Database_mysql Object

(

[dbh] => [error] => Access denied for user 'mythtv'@'localhost' (using password: YES) #1045 [err] => Access denied for user 'mythtv'@'localhost' (using password: YES) [errno] => 1045 [last_sh] => Database_Query_mysql Object

(

[dbh] => [query] => Array

(

[0] => SET NAMES utf8;

)

[last_query] => SET NAMES utf8; [warnings] => Array ( ) [num_args_needed] => 0 [num_rows] => [affected_rows] => [insert_id] => [db] => Database_mysql Object

*RECURSION*

)

[fatal_errors] => 1 [query_count] => 0 [query_time] => 0 [global_name] => [destruct_handlers] => Array ( )

)

[type] => -> [args] => Array

(

[0] => SET NAMES utf8;

)

)

[3] => Array

(

[file] => /usr/share/mythtv/mythweb/includes/database.php [line] => 49 [function] => connect [class] => Database

[type] =>
[args] => Array ( [0] => mythconverg [1] => mythtv [2] => 0E9KVMrl [3] => localhost [4] => [5] => mysql )

)

[4] => Array

(

[file] => /usr/share/mythtv/mythweb/includes/init.php [line] => 40 [args] => Array

(

[0] => /usr/share/mythtv/mythweb/includes/database.php

)

[function] => require_once

)

[5] => Array

(

[file] => /usr/share/mythtv/mythweb/mythweb.php [line] => 20 [args] => Array

(

[0] => /usr/share/mythtv/mythweb/includes/init.php

)

[function] => require_once

)

) !!

filename: /usr/share/mythtv/mythweb/classes/Database/Query/mysql.php

error line: 64

==========================================================================

Backtrace:

file: /usr/share/mythtv/mythweb/classes/Database/Query/mysql.php line: 64

class:

function: trigger_error

type: args: Array

(

[0] => Access denied for user 'mythtv'@'localhost' (using password: YES) #1045

Backtrace Array (

[0] => Array

(

[file] => /usr/share/mythtv/mythweb/classes/Database/Query/mysql.php [line] => 63 [function] => error [class] => Database [object] => Database_mysql Object

(

[dbh] => [error] => Access denied for user 'mythtv'@'localhost' (using password: YES) #1045 [err] => Access denied for user 'mythtv'@'localhost' (using password: YES) [errno] => 1045 [last_sh] => Database_Query_mysql Object

(

[dbh] => [query] => Array

(

[0] => SET NAMES utf8;

)

[last_query] => SET NAMES utf8; [warnings] => Array ( ) [num_args_needed] => 0 [num_rows] => [affected_rows] => [insert_id] => [db] => Database_mysql Object

*RECURSION*

)

[fatal_errors] => 1 [query_count] => 0 [query_time] => 0 [global_name] => [destruct_handlers] => Array ( )

)

[type] => -> [args] => Array ( )

)

[1] => Array

(

[file] => /usr/share/mythtv/mythweb/classes/Database.php [line] => 259 [function] => execute [class] => Database_Query_mysql [object] => Database_Query_mysql Object

(

[dbh] => [query] => Array

(

[0] => SET NAMES utf8;

)

[last_query] => SET NAMES utf8; [warnings] => Array ( ) [num_args_needed] => 0 [num_rows] => [affected_rows] => [insert_id] => [db] => Database_mysql Object

(

[dbh] => [error] => Access denied for user 'mythtv'@'localhost' (using password: YES) #1045 [err] => Access denied for user 'mythtv'@'localhost' (using password: YES) [errno] => 1045 [last_sh] => Database_Query_mysql Object

*RECURSION*

[fatal_errors] => 1 [query_count] => 0 [query_time] => 0 [global_name] => [destruct_handlers] => Array ( )

)

)

[type] => -> [args] => Array

(

[0] => Array ( )

)

)

[2] => Array

(

[file] => /usr/share/mythtv/mythweb/classes/Database.php [line] => 124 [function] => query [class] => Database [object] => Database_mysql Object

(

[dbh] => [error] => Access denied for user 'mythtv'@'localhost' (using password: YES) #1045 [err] => Access denied for user 'mythtv'@'localhost' (using password: YES) [errno] => 1045 [last_sh] => Database_Query_mysql Object

(

[dbh] => [query] => Array

(

[0] => SET NAMES utf8;

)

[last_query] => SET NAMES utf8; [warnings] => Array ( ) [num_args_needed] => 0 [num_rows] => [affected_rows] => [insert_id] => [db] => Database_mysql Object

*RECURSION*

)

[fatal_errors] => 1 [query_count] => 0 [query_time] => 0 [global_name] => [destruct_handlers] => Array ( )

)

[type] => -> [args] => Array

(

[0] => SET NAMES utf8;

)

)

[3] => Array

(

[file] => /usr/share/mythtv/mythweb/includes/database.php [line] => 49 [function] => connect [class] => Database

[type] =>
[args] => Array ( [0] => mythconverg [1] => mythtv [2] => 0E9KVMrl [3] => localhost [4] => [5] => mysql )

)

[4] => Array

(

[file] => /usr/share/mythtv/mythweb/includes/init.php [line] => 40 [args] => Array

(

[0] => /usr/share/mythtv/mythweb/includes/database.php

)

[function] => require_once

)

[5] => Array

(

[file] => /usr/share/mythtv/mythweb/mythweb.php [line] => 20 [args] => Array

(

[0] => /usr/share/mythtv/mythweb/includes/init.php

)

[function] => require_once

)

)

[1] => 256

)

file: /usr/share/mythtv/mythweb/classes/Database.php line: 259

class: Database_Query_mysql

function: execute

type: -> args: Array

(

[0] => Array ( )

)

file: /usr/share/mythtv/mythweb/classes/Database.php line: 124

class: Database

function: query

type: -> args: Array

(

[0] => SET NAMES utf8;

)

file: /usr/share/mythtv/mythweb/includes/database.php line: 49

class: Database

function: connect

type:
args: Array

(

[0] => mythconverg [1] => mythtv [2] => 0E9KVMrl [3] => localhost [4] => [5] => mysql

)

file: /usr/share/mythtv/mythweb/includes/init.php line: 40

class:

function: require_once

type: args: Array

(

[0] => /usr/share/mythtv/mythweb/includes/database.php

)

file: /usr/share/mythtv/mythweb/mythweb.php line: 20

class:

function: require_once

type: args: Array

(

[0] => /usr/share/mythtv/mythweb/includes/init.php

)

==========================================================================

$_SESSION: Array (

[language] => English

)

==========================================================================

$_SERVER: Array (

[REDIRECT_STATUS] => 200 [db_server] => localhost [db_name] => mythconverg [db_login] => mythtv [db_password] => 0E9KVMrl [HTTP_HOST] => datastorage [HTTP_USER_AGENT] => Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit?/536.25 (KHTML, like Gecko) Version/6.0 Safari/536.25 [HTTP_ACCEPT] => text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8 [HTTP_ACCEPT_ENCODING] => gzip, deflate [HTTP_ACCEPT_LANGUAGE] => en-us [HTTP_CONNECTION] => keep-alive [PATH] => /usr/local/bin:/usr/bin:/bin [SERVER_SIGNATURE] => <address>Apache/2.2.22 (Ubuntu) Server at datastorage Port 80</address>

[SERVER_SOFTWARE] => Apache/2.2.22 (Ubuntu) [SERVER_NAME] => datastorage [SERVER_ADDR] => 192.168.9.200 [SERVER_PORT] => 80 [REMOTE_HOST] => klement.local [REMOTE_ADDR] => 192.168.9.102 [DOCUMENT_ROOT] => /var/www [SERVER_ADMIN] => webmaster@localhost [SCRIPT_FILENAME] => /var/www/mythweb/mythweb.php [REMOTE_PORT] => 56652 [REDIRECT_URL] => /mythweb/ [GATEWAY_INTERFACE] => CGI/1.1 [SERVER_PROTOCOL] => HTTP/1.1 [REQUEST_METHOD] => GET [QUERY_STRING] => [REQUEST_URI] => /mythweb/ [SCRIPT_NAME] => /mythweb/mythweb.php [PHP_SELF] => /mythweb/mythweb.php [REQUEST_TIME] => 1346225969 [STATUS] => 200 [URL] => /mythweb/

)

==========================================================================

$constant_listuser?: Array (

[ERROR] => 512 [E_ASSERT_ERROR] => 4096 [FATAL] => 256 [PHP_MIN_VERSION] => 5.3 [WARNING] => 1024

)

Change History (4)

comment:1 Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

Priority: majorminor
Resolution: Invalid
Status: newclosed

Please search help on the mythtv-users mailing list.

comment:2 Changed 5 years ago by toddb@…

Resolution: Invalid
Status: closednew

same issue,

Cannot navigate to mythweb

in the config file /etc/apache2/sites-enabled/mythweb.conf: exists the entry

<Directory "/var/www/mythweb/data">

Options +All +FollowSymLinks? +IncludesNoExec?

</Directory>

and results in the follow error on start apache2:

The apache2 configtest failed. Output of config test was: AH00526: Syntax error on line 30 of /etc/apache2/sites-enabled/mythweb.conf: You may not use 'Options +All' or 'Options -All'. Action 'configtest' failed. The Apache error log may have more information.

removing +all fixes the start error but now creates the cant

comment:3 Changed 5 years ago by toddb@…

error string: NoTrans: Access denied for user 'mythtv'@'localhost' (using password: YES) #1045

fyi: running linux mint 16 x64, mythtv (2:0.27.0+fixes.20130919.5b917e8-0ubuntu1)

comment:4 Changed 5 years ago by sphery

Resolution: Invalid
Status: newclosed

Specifying the database password is required configuration for the user (or, when package managers take on the responsibility, for packaging scripts). That the defaults don't work for your system is not a bug in MythTV's configuration example (and, in truth, is simply an indication that you're attempting to configure your system well--with other-than-default credentials).

As for the Options line, please open a new ticket for that issue ("Options +All is no longer valid in Apache 2.4.x"), which is /very/ different from the misconfiguration shown in the original bug report (and indicated by your final comment).

Note: See TracTickets for help on using tickets.