Opened 7 years ago

Closed 6 years ago

#11068 closed Bug Report - General (Works for me)

frontend does not react to keyboard commands during DVD playback with 2 optical drives

Reported by: ericHyatt <ericroyhyatt@…> Owned by: stuartm
Priority: minor Milestone: unknown
Component: MythTV - DVD Playback Version: 0.25.2
Severity: medium Keywords: internal player, default device
Cc: markk Ticket locked: no

Description

case 0: my combined frontend/backend has a single optical drive (driveA). After starting DVD playback, many keyboard commands cause menus to appear, menu choices allow me to affect the playback. case 1: same machine with 2 optical drives (driveA & driveB). After DVD playback begins, no keyboard commands cause a popup to appear, and I can not control the playback, except by pressing "escape", which ends playback. case 2: same machine with a single optical drive (driveB). behavior same as case 0.

Attachments (1)

mv.txt (873 bytes) - added by ericHyatt <ericroyhyatt@…> 7 years ago.
mythfrontend version

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by ericHyatt <ericroyhyatt@…>

Attachment: mv.txt added

mythfrontend version

comment:1 Changed 7 years ago by Raymond Wagner

Could you open up a process list while the DVD is being played, and confirm it is actually mythfrontend and not some external player that is active?

comment:2 Changed 7 years ago by stuartm

The drive selection menu is possibly the last example of the 'old' UI code, it hasn't been ported yet because of the way it's integrated. This seems a lot like a focus issue, are you using a window manager?

In 0.26 that menu is only displayed if you have discs in both drives and by 0.27 it will be replaced entirely.

comment:3 Changed 7 years ago by blm-ubunet@…

Confirm same issue with mythtv .25+fixes on lucid 10.04 gnome. Using internal player. One DVD & one BD/DVD drive. Workaround is to move mouse to other screen & back to mythtv screen, then all is well. This problem & soln has been around for at least a year..

comment:4 in reply to:  3 Changed 7 years ago by blm-ubunet@…

Replying to blm-ubunet@…: Wrong bug & wrong workaround.. I find that I can not have a disk in both (2) optical drives. The optical drive dialogue has no effect. If a BD disk is present it always plays from the optical disk menu. BD playback requires a fixed mount point. My fixed mountpoint workaround was to use udev rule for 2nd drive (BD/DVD) & made it mount at /media/BD-DVD. Then I modified mythtv code to play BD from that path. This was also a failed attempt to fix the 2nd optical drive blocking the DVD drive..

Both drives work independently with other s/w.

Sorry for the noise..

comment:5 Changed 6 years ago by peper03

Resolution: Works for me
Status: newclosed

I've just tried this on 0.27 (current master) without any problems. I'm closing this ticket as 'Works for me'. Feel free to create a new ticket if the issue still occurs using only the internal player.

comment:6 Changed 6 years ago by blm-ubunet@…

Running master -1 week..& internal player. same setup as comment #5 above.

With 2 optical drives (1xBD/DVD & 1xDVD) & DVD's in both drives you never get prompted to choose..just plays DVD only drive.

With 2 optical drives (ditto) & BD in one & DVD in other, the BD always plays (no prompt).

Do you see a prompt that allows drive choice ?

Note: This is only a very minor issue for me, the situation does not arise in real-world usage.

comment:7 Changed 6 years ago by peper03

If a mounted BluRay? disc is found, it will be played first. Otherwise which DVD is chosen depends on the 'DVD Drive' setting.

However, this is not the problem described in the ticket. If you want to discuss this, you're welcome to do so on the mailing lists or IRC.

comment:8 Changed 6 years ago by stuartm

Milestone: unknown0.27
Resolution: Works for me
Status: closednew
Version: 0.25.2Master Head

With two DVDs in the drive, it should (and does for me) show a prompt asking which you wish to play. The only time it shouldn't ask is when only one disc is present.

One possibility is that the media monitor isn't running for some reason, or that it's failing to detect the presence of a disc in one drive or the other. Some logs with -v media, starting before inserting the discs would help.

comment:9 Changed 6 years ago by stuartm

Owner: set to stuartm
Status: newaccepted

comment:10 Changed 6 years ago by stuartm

Milestone: 0.27unknown
Resolution: Works for me
Status: acceptedclosed
Version: Master Head0.25.2

It's been pointed out to me that the original ticket was for a different issue to the one described by blm-ubunet and should have it's own ticket. The problem described by the original reporter isn't reproducible here with either 0.26 or master (0.27). So I'm re-closing the ticket and ask that you open a new ticket for any similar problems you may be having.

Note: See TracTickets for help on using tickets.