Opened 14 years ago

Closed 14 years ago

#1107 closed defect (fixed)

mythmusic hangs gui in full screen spectrum visualization

Reported by: ben@… Owned by: Isaac Richards
Priority: minor Milestone: 0.20
Component: mythmusic Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I am running svn 8688 and have noticed that mythmusic GUI locks up with a full screen visualization of spectrum (all others are ok).

Now this only happened when I switched the screen res to 1360 x 1024 for the new display I got If I switch back to 1024 x 768 the visualization plays fine. It also plays fine in the small preview window on the main mythmusic screen. I guess it must be something to do with the scaling of it.

By GUI lockup when I mean is that the screen freezes on its current image, and the keys stop responding. I have tried it both by having a different full screen visualization playing and chaning to spectrum, and have spectrum playing in the preview window, then switching to full screen. The music carries on playing in the background as though nothing is wrong.

Have added the backtrace file, but as it does not crash, not sure if its going to be usefull

Attachments (1)

gdb.txt (16.4 KB) - added by ben@… 14 years ago.
Back Trace

Download all attachments as: .zip

Change History (6)

Changed 14 years ago by ben@…

Attachment: gdb.txt added

Back Trace

comment:1 Changed 14 years ago by anonymous

Severity: highmedium

comment:2 Changed 14 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newassigned

I can reproduce this, so I'm going to have a crack at fixing it...

comment:3 Changed 14 years ago by danielk

Milestone: 0.20
Owner: changed from danielk to Isaac Richards
Status: assignednew

Fixed hang in [8795].

The problem is that LogScale::setMax() uses an iterative algorithm which does not always converge. [8795] increases the range of the floating point numbers so that it converges more often, and also limits the number of total iterations so that the hang never happens.

However, the Visualization is not very informative at higher resolutions. My guess is that the frequency scale is all wrong since we are increasing the number of bars but not the size of the FFT window. So I'm leaving the ticket open in case anyone cares to fix the functionality of the filter...

comment:4 Changed 14 years ago by anonymous

"However, the Visualization is not very informative at higher resolutions."

If this is meant to describe the fact that fullscreen visualization with Spectrum consists of one apparently well-behaved bar on the left and N duplicate bars on the right, all moving up and down in concert, then there's no need to report that as a separate bug.

comment:5 Changed 14 years ago by Isaac Richards

Resolution: fixed
Status: newclosed

Bug's ancient, and the problem was fixed ages ago.

Note: See TracTickets for help on using tickets.