Opened 7 years ago

Closed 6 years ago

#11070 closed Bug Report - Crash (Works for me)

Crash in before MFE main window drawn

Reported by: Craig Treleaven <ctreleaven@…> Owned by: JYA
Priority: minor Milestone: unknown
Component: Ports - OSX Version: 0.25.2
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Multiple users are reporting that mythfrontend on OS X crashes before drawing the main window. Details, including logs and OS X crash reports are at https://trac.macports.org/ticket/35934

Crash reports indicate MythMainWindow::Init calls QWidget::setWindowFlags, etc leading to the exception. MacPorts? version is built with Qt 4.8.2. Note that mythfrontend built with the osx-packager-qtsdk works OK--believe this would be an older version of Qt.

Attachments (6)

mythfrontendTerminalOut_OSX10-7-4.log (2.9 KB) - added by Craig Treleaven <ctreleaven@…> 7 years ago.
mythfrontendCrashReport_OSX10-7-4.log (50.6 KB) - added by Craig Treleaven <ctreleaven@…> 7 years ago.
mythfrontendTerminalOut.log (3.4 KB) - added by Craig Treleaven <ctreleaven@…> 7 years ago.
mythfrontendCrashReport.log (49.6 KB) - added by Craig Treleaven <ctreleaven@…> 7 years ago.
MFE version.txt (739 bytes) - added by Craig Treleaven <ctreleaven@…> 7 years ago.
MFE.app error 2012Sep07.txt (8.7 KB) - added by Craig Treleaven <ctreleaven@…> 7 years ago.
Related (?) error in app produced by official packaging

Download all attachments as: .zip

Change History (14)

comment:1 Changed 7 years ago by JYA

Resolution: Invalid
Status: newclosed

I always build against stock 4.8.2, and never ever saw that crash...

Considering I will only support at this stage something build with myth official packager, and that it uses stock qt and not the heavily patched one from mac port, I will close this as invalid.

If you have backtraces, use myth trac. I don't look at external bug system.

comment:2 Changed 7 years ago by Craig Treleaven <ctreleaven@…>

Resolution: Invalid
Status: closednew

comment:3 in reply to:  1 Changed 7 years ago by Craig Treleaven <ctreleaven@…>

Replying to jyavenard:

... If you have backtraces, use myth trac. I don't look at external bug system.

Will attach. Key points -

Several people have built and run Myth from MacPorts?. This issue affects a subset but is a repeatable crash for them. Affects 10.7.4, 10.8.1 and 10.8.2 on machines ranging from a Mac Mini to a Mac Pro. Eg, one user has three machines all exhibiting the problem:

2009 Mac Pro running OSX 10.8.1 2011 Macbook Pro running OSX 10.8.1 Mid 2010 Mac Mini running OSX 10.7.4. The backend is Ubuntu (precise) running mythtv backend 2:0.25.2+fixes.20120828.d519276-0ubuntu0mythbuntu4.

Both users are connecting to a remote backend running Linux but the crash seems to happen early in the launch of mythfrontend so I don't see how that could contribute to the problem. One user reports that he is able to run mythtv-setup successfully. (The other migrated to 0.26 before testing further.)

MacPorts? Qt is used by dozens of ports and there are no reports of similar problems. But if this is a problem with the MacPorts? Qt, the port maintainer would appreciate knowing.

Changed 7 years ago by Craig Treleaven <ctreleaven@…>

Changed 7 years ago by Craig Treleaven <ctreleaven@…>

Changed 7 years ago by Craig Treleaven <ctreleaven@…>

Attachment: mythfrontendTerminalOut.log added

Changed 7 years ago by Craig Treleaven <ctreleaven@…>

Attachment: mythfrontendCrashReport.log added

Changed 7 years ago by Craig Treleaven <ctreleaven@…>

Attachment: MFE version.txt added

comment:4 Changed 7 years ago by JYA

That may very well be... But you can't expect me to troubleshoot and find a bug that do not show when you use stock Qt....

The crash occurs in libunwind that just a few minutes ago didn't even know existed...

I just don't have to time bandwidth to do so..

Reproduce it with stock Qt, and then we'll see

comment:5 Changed 7 years ago by Craig Treleaven <ctreleaven@…>

See attached MFE log, report "kCGErrorIllegalArgument: CGSOrderWindowList"--I believe this is an analogous error to that which leads to a crash on other machines. My MacPorts? frontend logs contain the same two error lines.

From spelunking the code (which is a dangerous thing for me), I notice that mythtv/programs/mythfrontend/main.cpp (starting at line 1615) seems to be somewhat different from mythtv/programs/mythtv-setup/main.cpp (see line 349 and then line 486). The difference is that mythtv-seup calls gCoreContext->SetSetting?("Theme", DEFAULT_UI_THEME); -- mythfrontend only does gCoreContext->GetSetting?("Theme", DEFAULT_UI_THEME); --no SetSetting?. Maybe it is nothing...thought it was worth mentioning.

Also, the app crashed on exit. I have the crash report if you want it but I don't think it is related to the issue at hand.

Changed 7 years ago by Craig Treleaven <ctreleaven@…>

Attachment: MFE.app error 2012Sep07.txt added

Related (?) error in app produced by official packaging

comment:6 Changed 7 years ago by Craig Treleaven <ctreleaven@…>

It appears that XCode 4.4 is the cause of the problem. One of the affected users, James George, put a tremendous amount of work into tracking down the issue. We eventually determined that the code would run successfully if built with apple-gcc-4.2. James has determined that code produced with XCode 4.3.3 works OK; XCode 4.4.0+ leads to crashes. Testing done on 10.7.4.

There were no obvious errors reported in the XCode 4.4.0+ builds.

More details at:

https://trac.macports.org/ticket/35934

comment:7 Changed 7 years ago by JYA

I build with Xcode 4.4 since the first beta was available, using llvm (not llvm-gcc) with no problem at all.

Try building without using gcc. Gcc hasn't been upgraded since Xcode 4.1 and will be removed in the next version of Xcode.

comment:8 Changed 6 years ago by JYA

Resolution: Works for me
Status: newclosed
Note: See TracTickets for help on using tickets.