Opened 7 years ago

Closed 6 years ago

#11080 closed Bug Report - General (Fixed)

Switching tuners via OSD kills ongoing recording

Reported by: warpme@… Owned by: danielk
Priority: minor Milestone: 0.27
Component: MythTV - Recording Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I consider this as serious as bug affecting critical MythTV function: recording. When user starts LiveTV and via OSD changes tuner to virtual tuner on currently recording phy. tuner - 1 for 3-5 cases ongoing recording will be killed. After that, usually LiveTV is not starting (TL_). Also trying to play this halted recording sometimes stalls FE.
Steeps to reproduce:

assuming You have tuners A & B, 2 virtual (1,2) tuners on each.

1.schedule recording on tuner A1

2.start LiveTV on tuner B2

3.go to OSD and switch B2->A2

4.after few Ax<->By switches, LiveTV stalls with TL_ and recording on A1 is killed.
BE log & trace for errant BE state when LiveTV not starts anymore attached. (btw: ignore tons of CRC error entries - test was on channel which has them, but working well).

Attachments (2)

mythbackend.20120910071020.25749.log.zip (632.4 KB) - added by warpme@… 7 years ago.
be log
trace.txt.zip (9.4 KB) - added by warpme@… 7 years ago.
BE trace

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by warpme@…

be log

Changed 7 years ago by warpme@…

Attachment: trace.txt.zip added

BE trace

comment:1 Changed 6 years ago by warpme@…

Problem seems to be fixed in 0.27. I just checked with 4phy/20virtual tuners. Cycling 20times across all them and no problem. Ticket can be closed. Thx!!!

comment:2 Changed 6 years ago by stuartm

Milestone: unknown0.27
Resolution: Fixed
Status: newclosed
Note: See TracTickets for help on using tickets.