Opened 7 years ago

Closed 7 years ago

#11090 closed Bug Report - General (Duplicate)

Lossless Transcodes Fail

Reported by: scott.harris0509@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - Mythtranscode Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

Since upgrading from 0.25 to 0.26, lossless transcodes that worked almost 100% of the time have begun to fail 100% of the time. Every transcode seems to fail with the log entry "(AddFrame?) Deadlock detected. One buffer is full when the other is empty! Aborting"

Attached is a log from one morning trying to transcode 2 different shows.

Current system is Mythbuntu 0.25, output of mythbackend --version:

MythTV Version : v0.26-rc2-16-g9b526cc MythTV Branch : master Network Protocol : 75 Library API : 0.26.20120822-1 QT Version : 4.8.1 Options compiled in:

linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv using_ivtv using_joystick_menu using_libcec using_libcrypto using_libdns_sd using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_live using_mheg using_libass using_libxml2

Attachments (4)

mythtranscode.log (29.6 KB) - added by scott.harris0509@… 7 years ago.
transcode logs attempting to lossless transcode 3 files
transcode.log (79.0 KB) - added by aaron@… 7 years ago.
transcoding log
mythtranscode.2.log (8.4 KB) - added by nexzzt 7 years ago.
mythtranscode-error.log (78.6 KB) - added by frankm 7 years ago.
mythtranscode -v all -m --chanid 2105 --starttime 20130305190400

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by scott.harris0509@…

Attachment: mythtranscode.log added

transcode logs attempting to lossless transcode 3 files

comment:1 Changed 7 years ago by scott.harris0509@…

I mistyped that, my current system is MythBuntu? 12.04, not 0.25.

comment:2 Changed 7 years ago by Robert Kulagowski

rkulagow@opti:~/mythtv.orig$ git bisect skip
There are only 'skip'ped commits left to test.
The first bad commit could be any of:
52be9885d38cdaa7a70660c66245c20fa8f87008
4300f0ed018d524c311d969c47ef5c4fdc906fcd
9cb02dee588127240fb8a843ed92347a33c7e0e1
940dd94d1ac092f61d9eebab542c96b7b54b7d45
96787dfe6ecbd9e1570c9ba4e587def0f46c2e38
6c3653cd378aacef10b7706d8b7f71beae41274c
We cannot bisect more!
rkulagow@opti:~/mythtv.orig$ git bisect log
git bisect start
# bad: [30f6e33cc25191a8b57492cdc1868845eaa713d8] Fixes #11072.  Improve cc708 thread safety.
git bisect bad 30f6e33cc25191a8b57492cdc1868845eaa713d8
# good: [3f6ae11d93577e7ea6ed0b7535ed31834a8837b5] Log the Qt version on startup
git bisect good 3f6ae11d93577e7ea6ed0b7535ed31834a8837b5
# bad: [266ebc25bd2b99cbefad26a0fd0a2b1af8bc982b] Translate the Blu Ray regions in the settings pages.
git bisect bad 266ebc25bd2b99cbefad26a0fd0a2b1af8bc982b
# bad: [13209ebcb37cbb6090a2747043c0131f6f25e394] Fix 'Show Upcoming' context menu entry in the Guide.
git bisect bad 13209ebcb37cbb6090a2747043c0131f6f25e394
# bad: [acc4cd4bc2cf4f320b56d8ecdfaf737af047bbfe] Rework RecorderBase::AspectChange() so it can't cause divide by zero.
git bisect bad acc4cd4bc2cf4f320b56d8ecdfaf737af047bbfe
# bad: [53c22345d7f00ad93924150a253c0d1bb0519f17] Fix possible divide by zero identified by Coverity
git bisect bad 53c22345d7f00ad93924150a253c0d1bb0519f17
# skip: [9e1ba1c8de42ec67664bb18076d90b0c34764209] Add AS_O and CXX_O to configure - fix ppc build
git bisect skip 9e1ba1c8de42ec67664bb18076d90b0c34764209
# skip: [098c103f67e6e93ba927d82d2d9433203a74eb1c] Merge branch 'devel/ffmpeg-sync-20120331'
git bisect skip 098c103f67e6e93ba927d82d2d9433203a74eb1c
# bad: [77d006bfd1d05092fbeafe1297a63e707f8b4291] Add byteswap_h and sys_endian_h back to HAVE_LIST
git bisect bad 77d006bfd1d05092fbeafe1297a63e707f8b4291
# skip: [75eafd40831b4ccfd451191fb25efd6861eeea76] Fix goom to use av_get_cpu_flags() from current ffmpeg
git bisect skip 75eafd40831b4ccfd451191fb25efd6861eeea76
# skip: [449d36dec79bd97cebd4fee3e19ab7224689ecc5] Fixed a couple more ffmpeg _encode_* API deprecations
git bisect skip 449d36dec79bd97cebd4fee3e19ab7224689ecc5
# bad: [e41a2832d6848186f940a5834a71d63ea3c4ed3d] Fixed RAOP audio decoding to use all frames in a packet
git bisect bad e41a2832d6848186f940a5834a71d63ea3c4ed3d
# bad: [6c3653cd378aacef10b7706d8b7f71beae41274c] Make it all compile...
git bisect bad 6c3653cd378aacef10b7706d8b7f71beae41274c
# skip: [52be9885d38cdaa7a70660c66245c20fa8f87008] Cumulated changes from previous sync
git bisect skip 52be9885d38cdaa7a70660c66245c20fa8f87008
# skip: [9cb02dee588127240fb8a843ed92347a33c7e0e1] Make it compile at least the ffmpeg part
git bisect skip 9cb02dee588127240fb8a843ed92347a33c7e0e1
# skip: [4300f0ed018d524c311d969c47ef5c4fdc906fcd] FFmpeg sync as of 03/31/2012
git bisect skip 4300f0ed018d524c311d969c47ef5c4fdc906fcd
# skip: [940dd94d1ac092f61d9eebab542c96b7b54b7d45] Roll-up of all changes after the previous sync
git bisect skip 940dd94d1ac092f61d9eebab542c96b7b54b7d45
# skip: [96787dfe6ecbd9e1570c9ba4e587def0f46c2e38] Remove old ffmpeg contents
git bisect skip 96787dfe6ecbd9e1570c9ba4e587def0f46c2e38


rkulagow@opti:~/mythtv.orig$ git bisect log | grep bad
# bad: [30f6e33cc25191a8b57492cdc1868845eaa713d8] Fixes #11072.  Improve cc708 thread safety.
git bisect bad 30f6e33cc25191a8b57492cdc1868845eaa713d8
# bad: [266ebc25bd2b99cbefad26a0fd0a2b1af8bc982b] Translate the Blu Ray regions in the settings pages.
git bisect bad 266ebc25bd2b99cbefad26a0fd0a2b1af8bc982b
# bad: [13209ebcb37cbb6090a2747043c0131f6f25e394] Fix 'Show Upcoming' context menu entry in the Guide.
git bisect bad 13209ebcb37cbb6090a2747043c0131f6f25e394
# bad: [acc4cd4bc2cf4f320b56d8ecdfaf737af047bbfe] Rework RecorderBase::AspectChange() so it can't cause divide by zero.
git bisect bad acc4cd4bc2cf4f320b56d8ecdfaf737af047bbfe
# bad: [53c22345d7f00ad93924150a253c0d1bb0519f17] Fix possible divide by zero identified by Coverity
git bisect bad 53c22345d7f00ad93924150a253c0d1bb0519f17
# bad: [77d006bfd1d05092fbeafe1297a63e707f8b4291] Add byteswap_h and sys_endian_h back to HAVE_LIST
git bisect bad 77d006bfd1d05092fbeafe1297a63e707f8b4291
# bad: [e41a2832d6848186f940a5834a71d63ea3c4ed3d] Fixed RAOP audio decoding to use all frames in a packet
git bisect bad e41a2832d6848186f940a5834a71d63ea3c4ed3d
# bad: [6c3653cd378aacef10b7706d8b7f71beae41274c] Make it all compile...
git bisect bad 6c3653cd378aacef10b7706d8b7f71beae41274c

comment:3 Changed 7 years ago by thatguruguy@…

I'm having this same issue on Mythbuntu 12.04 with MythTV .26. Has there been any progress?

comment:4 Changed 7 years ago by aaron@…

This is happending to me on all 3 of my myth systems. (2 frontends and 1 backend). Using newest .26-fixes.

I have tried mythtranscode wiki page with the deadlock detected troubleshooting section. Still same issue.

Attached my transcoding log.

Changed 7 years ago by aaron@…

Attachment: transcode.log added

transcoding log

comment:5 Changed 7 years ago by dheianevans@…

Add my name to the list. Really miss the lossless transcodes!

comment:6 in reply to:  5 Changed 7 years ago by Raymond Wagner

Ticket locked: set

Replying to dheianevans@…:

Add my name to the list. Really miss the lossless transcodes!

That's not how these things work...

Changed 7 years ago by nexzzt

Attachment: mythtranscode.2.log added

Changed 7 years ago by frankm

Attachment: mythtranscode-error.log added

mythtranscode -v all -m --chanid 2105 --starttime 20130305190400

comment:7 Changed 7 years ago by Karl Egly

Resolution: Duplicate
Status: newclosed

This appears to be a duplicate of #2077, see the latest comments over there.

All attached logfiles contain AC3 audio tracks which the patch in #2077 is supposed to fix, please test and report back over there.

Note: See TracTickets for help on using tickets.