Opened 7 years ago

Closed 22 months ago

#11116 closed Developer Task (Won't Fix)

Watched icon doesn't get updated on themes after watching a video

Reported by: hackedbellini@… Owned by: stuartm
Priority: minor Milestone: 0.28.2
Component: MythTV - Video Playback Version: Master Head
Severity: low Keywords:
Cc: Ticket locked: yes

Description

I first reported this on steppes theme[1], but the dev there told me that this is probably a problem on your side..so here it is:

When watching a video and having the option to "Automatically mark it as watched", after seeing the video, the icon does not get updated.

The process of marking it as watched works, but I can only see that changes after I "Scan for changes".

On 0.25, that used to happen even when I manually marked a video as "Watched", but on 0.26 it was fixed.

[1] https://github.com/MythTV-Themes/Steppes/issues/1

Change History (12)

comment:1 Changed 6 years ago by Karl Egly

Component: MythTV - GeneralMythTV - Video Playback
Status: newinfoneeded_new

Is this still an issue? Is this with the internal video player? Can you post the version you are using?

comment:2 in reply to:  1 Changed 6 years ago by hackedbellini@…

Replying to dekarl:

Is this still an issue?

I don't know about 0.27, but on 0.26 this is still an issue. I'm using Mythbuntu with this ppa [1] that as you can see, is using the last mythtv from branch 'fixes/0.26' [2]

Is this with the internal video player?

With the internal video player I expect this issue to really happen =P.

But no, this happens with the internal player too. The exactly way to reproduce is:

1) Watch a video with the option "Automatically mark it as watched" set 2) After watching it, see that it's "watched" flag isn't set (since the video info menu presents an option to "Mark as watched" and not the opposite) 3) But the flag is kind of lazily set since when doing a "Scan for changes" it's now marked as watched

Actually number 3 sometimes isn't true, but then there's another issue (the "Mark as watched" is not reliable depending on how the video was stopped), but when it does the right thing (setting it as watched) I can only see the flag setted after scanning for changes.

Can you post the version you are using?

0.26 + fixes

[1] https://launchpad.net/~mythbuntu/+archive/0.26 [2] https://github.com/MythTV/mythtv/commits/fixes/0.26

comment:3 Changed 6 years ago by sphery

hackedbellini, are you using the Qt painter? Does this also occur with the OpenGL painter.

Paint engine This selects what MythTV uses to draw. Choosing 'Auto' is recommended, unless running on systems with broken OpenGL implementations (broken hardware or drivers or windowing systems) where only Qt works.

comment:4 Changed 6 years ago by hackedbellini@…

Hi,

When I reported this, I was using OpenGL and the latest MythTV version.

I don't know if the issue is still reproducible because I'm not using mythtv anymore. I acquired a raspberry pi and since mythtv does not run on it, unfortunately, I have to move to xbmc.

comment:5 Changed 6 years ago by yiannividalis@…

Hi, yes, I can confirm the issue occurs with the OpenGL painter, using late-ish master (v0.28-pre-1041-ga0a32ef-dirty). To see the watched icon "on" I have to exit and re-visit mythvideo.

comment:6 Changed 6 years ago by sphery

Status: infoneeded_newnew

comment:7 Changed 6 years ago by yiannividalis@…

Here is what I've observed, it may help solve this issue:

The behaviour is independent of the painter used. I've tested it with Qt, OpenGL1 and OpenGL2 with the same results, using the Steppes theme.

In MythVideo?, I have Folders like Series-->SeriesName?--> SeriesName? S01E01.mkv, SeriesName? S01E02.mkv, etc

View Mode:List    |View episode to end | After exiting to parent folder    | After exiting to main |
                  |                    | and reentering same series folder | menu and reentering   |
------------------+--------------------+-----------------------------------+-----------------------|
"I" menu offers to|  Mark as Watched   | Mark as Watched                   | Mark as Unwatched     |
------------------+--------------------+-----------------------------------+-----------------------|
"Watched" icon is |       Off          |      On                           |        On             |

===================================================================================================

View Mode:Browse  |View episode to end | After exiting to parent folder    | After exiting to main |
                  |                    | and reentering same series folder | menu and reentering   |
------------------+--------------------+-----------------------------------+-----------------------|
"I" menu offers to|  Mark as Watched   | Mark as Watched                   | Mark as Unwatched     |
------------------+--------------------+-----------------------------------+-----------------------|
"Watched" icon is |       Off          |      Off                          |        On             |



I hope the above primitive table illustrates the behaviour I've observed. Please let me know what else I can provide to help solving this.

ythTV Version : v0.28-pre-1041-ga0a32ef
MythTV Branch : master
Network Protocol : 80
Library API : 0.28.20140327-1
QT Version : 4.8.5
Options compiled in:
 linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_dvb using_frontend using_ceton using_hdpvr using_ivtv using_libcrypto using_libfftw3 using_libxml2 using_libudf using_mheg using_opengl using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_taglib using_v4l2 using_x11 using_xrandr using_xv using_profiletype using_mythlogserver using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_mheg using_libass using_libxml2 using_libudf

comment:8 Changed 6 years ago by stuartm

Milestone: unknown0.28
Owner: set to stuartm
Severity: mediumlow
Status: newaccepted
Type: Bug Report - GeneralDeveloper Task

This isn't a bug as such, it was simply never implemented.

comment:9 Changed 6 years ago by stuartm

Ticket locked: set

comment:10 Changed 4 years ago by Stuart Auchterlonie

Milestone: 0.280.28.1

Moving unresolved tickets to next point release

comment:11 Changed 3 years ago by Stuart Auchterlonie

Milestone: 0.28.10.28.2

Moving remaining open 0.28.1 tickets to 0.28.2

comment:12 Changed 22 months ago by Stuart Auchterlonie

Resolution: Won't Fix
Status: acceptedclosed

Closing any remaining tickets for 0.28, if the issue persists, feel free to reopen and align to v29 or master

Note: See TracTickets for help on using tickets.