Opened 7 years ago

Closed 7 years ago

#11128 closed Bug Report - General (Won't Fix)

UPnP playback of recordings broken in 0.25

Reported by: tradke@… Owned by: dblain
Priority: minor Milestone: unknown
Component: MythTV - UPnP Version: 0.25.2
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After upgrading from 0.24 to 0.25 I cannot play recordings via XBMC and UPnP. The content directory is shown correctly, but if I click on an item the server says that the item could not be found. From mythbackend.log and browsing the source code I think I found the cause: When delivering the content, the server assigns an Id to each entry from the recordings table. The Id is composed of channel id and start time. The start time is converted to UTC before using it as Id. But when the client requests that item, the channel id and start time is used for the select in the recordings table, but not converted back to local time. So the item cannot be found in database.

Attachments (1)

xbmc_to_mythtv.log (157.3 KB) - added by tradke@… 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by tradke@…

Attachment: xbmc_to_mythtv.log added

comment:1 Changed 7 years ago by dbuttrick@…

I have a Sony BDP-S390 that I use as my frontend in the living room. With 0.24, playback of any content was just fine. I upgraded to 0.25 and now I cannot playback anything.

Here is what I notice from the Sony's UI: Browsing DLNA works just fine. When I get to a list of recordings or videos, the UI on the BDP-S390 shows a little icon of the filetype it is going to try to play. It thinks all of the files are AVI files, regardless of the Mime Type or file extension. The consequence of this is that AVI files playback just fine (I have about 3 of them, the rest are mpeg or mp4)

So, i know that the streamer parts are all fit together properly, Somewhere in process of generating the list of files, or in the BDP-S390's interpretation of that list, there is a problem where the player isn't able to make the right decisions about what to do.

Does this help at all? What logging information can I provide to help troubleshoot this?

Thanks.

comment:2 Changed 7 years ago by Raymond Wagner

Resolution: Won't Fix
Status: newclosed

I'm closing this one because the description of the problem seems to indicate it should be fixed automatically by the migration to UTC in 0.26.

Note: See TracTickets for help on using tickets.