Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11175 closed Bug Report - General (Duplicate)

Live TV exits on channel change or program change.

Reported by: straximus@… Owned by: Jim Stichnoth
Priority: minor Milestone: 0.26.1
Component: MythTV - General Version: 0.26-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When attempting to change the channel on Live TV, or when the program changes on the channel being viewed, Live TV exits with the message "Video frame buffering failed too many times."

In our system, this only occurs when using a PVR-500 tuner. It doesn't affect our HDHomerun tuners. To avoid the issue when changing channels, we appear to be able to change to a channel on the HDHomerun, and then back to a channel on the PVR-500 without issue.

We have a combined Frontend/Backend? running on a Athlon II X4 635 CPU, Asus M3N78-VM Motherboard, with 4GB of RAM. Running Mythbuntu 12.04 with 0.26-fixes. ( 0.26.0+fixes.20121013.aae34c4 )

Attachments (2)

mythbackend.log (5.9 KB) - added by straximus@… 7 years ago.
mythfrontend.log (47.9 KB) - added by straximus@… 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by straximus@…

Attachment: mythbackend.log added

Changed 7 years ago by straximus@…

Attachment: mythfrontend.log added

comment:1 Changed 7 years ago by adacey@…

I have the same issue with a wintv-pvr-usb2 tuner. Recordings work fine but when I watch Live TV it's always on the same channel and changing the channel causes this crash. Similarly, if I'm watching Live TV I'll see the same type of crashing when the program ends.

comment:2 Changed 7 years ago by melvincwb@…

I also have this issue. I have a pvr150. The error occurred when a program change happens on the same channel then kicks me back out to the main menu with the error. Changing Channels works fine.

My issue started after upgrading from 0.25 to 0.26

comment:3 Changed 7 years ago by straximus@…

The Feb 3rd commit to 0.26-fixes for this issue appears to have resolved it for me. I just changed analog channels over a dozen times without incident. I've also watched one program rollover into the next without issue.

Thanks!

comment:4 Changed 7 years ago by Jim Stichnoth

Owner: set to Jim Stichnoth
Status: newaccepted

comment:5 Changed 7 years ago by Jim Stichnoth

Milestone: unknown0.26.1
Resolution: Duplicate
Status: acceptedclosed

Marking as a duplicate of #11211, which was dixed in a1b9b1f94a774710443637de034c661618e5baa3.

Note that this fixes a specific regression introduced in 0.26. Live TV bugs present in 0.25 may still be lurking.

Thanks for reporting back.

comment:6 Changed 7 years ago by adacey@…

Confirmed channel change is working for me now. I notice some slight stuttering or choppy playback when I change but it seems to clear up. I think that's new but it's been so long since i've had it working I can't say for certain.

Note: See TracTickets for help on using tickets.