Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1122 closed defect (fixed)

8703 breaks XvMC-VLD on EPIA

Reported by: Jon Whitear Owned by: danielk
Priority: minor Milestone: 0.19
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by danielk)

I've just upgraded both frontend (diskless EPIA M10k, Gentoo, 2.6.7) and backend from 8695 to SVN 8725.

Pre-recorded TV plays fine (recordings made before and after upgrade) but LiveTV fails. Here's the frontend log on entering LiveTV.

Cheers,

Jon

Attachments (16)

logsandbacktrace.txt (16.2 KB) - added by anonymous 14 years ago.
mfe.log (13.6 KB) - added by mino 14 years ago.
mythfrontend -v playback 8738
1122.patch (1.9 KB) - added by danielk 14 years ago.
debugging patch
gdb.txt (607 bytes) - added by TimJordan 14 years ago.
mythfrontend.log (28.5 KB) - added by TimJordan 14 years ago.
frontend_8742.log (16.7 KB) - added by HidDEN MiNdS 14 years ago.
Frontend r8742 stdout
frontend_8742.err (25 bytes) - added by HidDEN MiNdS 14 years ago.
Frontend r8742 stderr
gdb_frontend_8742.txt (14.6 KB) - added by HidDEN MiNdS 14 years ago.
gdb segfault backtrace r8742 selecting LiveTV enabled Via XvMC
noshow (229.6 KB) - added by John 14 years ago.
"Error was encountered while displaying video" but on a matrox g400 - live tv with r8742
noshow.2 (105.1 KB) - added by John 14 years ago.
"Error was encountered while displaying video" but on a matrox g400 - live tv with r8742 (correct trace)
1122-fix-v2.patch (4.8 KB) - added by danielk 14 years ago.
Possible fix for EPIA XvMC
mythfrontend.2.log (27.8 KB) - added by TimJordan 14 years ago.
1122-fix-v3.patch (7.6 KB) - added by danielk 14 years ago.
adds some debugging to v2 of the patch
1122-fix-v4.patch (2.0 KB) - added by danielk 14 years ago.
Update of v4 to apply to current SVN
mythfrontend.3.log (70.6 KB) - added by TimJordan 14 years ago.
latest svn with v4 patch applied
svn8759.log (45.5 KB) - added by john 14 years ago.
UK-DVB_T mythfrontend -v playback

Download all attachments as: .zip

Change History (47)

Changed 14 years ago by anonymous

Attachment: logsandbacktrace.txt added

comment:1 Changed 14 years ago by rob.r@…

I have the same problem. I was using 8696, and XVMC broke after an upgrade. I am using the Nvidia 8178 driver. I fully purged my Myth build direcotires and re-built, but the problem persisted. I then reverted back to 8696 and it's back to working again without any problems. I've attached the relevant parts of the log and a backtrace.

comment:2 Changed 14 years ago by johan@…

Summary: Upgrade from SVN 8695 -> 8725 breaks LiveTV [DVB / XVMC-VLD]Upgrade to > SVN 8696 breaks LiveTV [ DVB / XVMC (VLD/NVIDIA) ]

I have exactly the same problem, except with the nVidia XvMC (driver version 7676). XvMC always worked until upgrading to 8725.

I deleted my source tree and checked out 8728 from scratch, which also exhibits the same problem. I have also re-installed my nVidia drivers to no effect.

I will look at attaching logs and a backtrace in about 12 hours when I get home from work (if it's not fixed by then :).

Obviously it's a commit that happened between 8696 and 8725, as the previous poster indicates.

comment:3 Changed 14 years ago by Isaac Richards

Finding the exact checkin that broke things would be helpful.

comment:4 Changed 14 years ago by adrian.wilkins@…

Have perused the changesets, and decided that the most likely revisions at which this may have broken are....

8703
8704
8706
8717
8719
8722

Forgive my unfamiliarity with the codebase if this seems incorrect (this is a start, eh?).

I too am suffering from this problem. Most unpleasant visual glitch artefacts occur. The crash has a nasty habit of taking the whole box down. Yet recordings (from the same channel and the same programme that caused LiveTV to choke) work just fine.

I shall try 8706, then we will have halved the potential culprits.

comment:5 Changed 14 years ago by Jon Whitear

I'm just building 8716 - it takes a while on my EPIA.

comment:6 Changed 14 years ago by danielk

Milestone: 0.19
Owner: changed from Isaac Richards to danielk
Version: head

I'll look at this when you find the breaking commit...

comment:7 Changed 14 years ago by danielk

Description: modified (diff)

Please test with the latest SVN, in case [8737] fixed this.

I need a full "mythfrontend -v playback" log with the latest SVN anyway..

Changed 14 years ago by mino

Attachment: mfe.log added

mythfrontend -v playback 8738

comment:8 Changed 14 years ago by Jon Whitear

8716 is broken for me. I'll try 8738, but I'm away for a couple of days, so won't be get to it until Monday.

comment:9 Changed 14 years ago by mino

On my system using XvMC with a nVidia 5200 version 8702 works and 8703 seg faults. 8738 also seg faults. I attached the mythfrontend -v playback log of the 8738 seg fault. I'll work on getting a backtrace and see if it is the same as the one attached.

comment:10 Changed 14 years ago by buzz <buzz@…>

is this the same fault as #1058?

comment:11 Changed 14 years ago by anonymous

This might be related, but my epia box is been crashing a lot in the last month on liveTV (not DVB but on ordinary TV too). Prerecorded shows run fine. Haven't posted a ticket because the log never reveal anything. Haven't tried a trace though... If you could tell me how to do a trace, I could generate one.

comment:12 Changed 14 years ago by adrian.wilkins@…

Confirm that 8706 suffers from this problem (for me, GF4MX integrated mobo GPU, 7667 driver.)

Will test 8702 - 8703 at weekend, unless someone beats me to it first :-)

comment:13 Changed 14 years ago by danielk

Summary: Upgrade to > SVN 8696 breaks LiveTV [ DVB / XVMC (VLD/NVIDIA) ]8703 breaks XvMC-VLD on EPIA

Changed 14 years ago by danielk

Attachment: 1122.patch added

debugging patch

comment:14 Changed 14 years ago by danielk

Can someone send me the "mythfrontend -v playback" output with the 1122.patch applied?

I also need a backtrace with the current SVN. The directions for making a backtrace are linked to from the TicketHowTo.

My guess is that the VideoOutputXv? is blocking the reuse of the only port on the EPIA available for decoding 1080i material because it is already being used by VideoOutputXv?; the patch should confirm that. But even so there shouldn't be a segfault, MythTV should be falling back to another output method or bailing out of video playback, which is why I need an up to date backtrace.

Changed 14 years ago by TimJordan

Attachment: gdb.txt added

Changed 14 years ago by TimJordan

Attachment: mythfrontend.log added

comment:15 Changed 14 years ago by TimJordan

As requested. My frontend doesn't crash thought just brings up a 'There has been a problem displaying video' message

comment:16 Changed 14 years ago by HidDEN MiNdS

I am having the same problem: Selecting LiveTV with XvMC Via causes the frontend to segfault.

My box has a Via unichrome pro chip.

I have just updated my version to 8742 and will attach the logs as requested. First the logs with your 1122.patch applied.

Tomorrow I can provide a backtrace too, but first I have to emerge gdb on this (slow) Gentoo box. :-/

Changed 14 years ago by HidDEN MiNdS

Attachment: frontend_8742.log added

Frontend r8742 stdout

Changed 14 years ago by HidDEN MiNdS

Attachment: frontend_8742.err added

Frontend r8742 stderr

Changed 14 years ago by HidDEN MiNdS

Attachment: gdb_frontend_8742.txt added

gdb segfault backtrace r8742 selecting LiveTV enabled Via XvMC

Changed 14 years ago by John

Attachment: noshow added

"Error was encountered while displaying video" but on a matrox g400 - live tv with r8742

Changed 14 years ago by John

Attachment: noshow.2 added

"Error was encountered while displaying video" but on a matrox g400 - live tv with r8742 (correct trace)

comment:17 Changed 14 years ago by John

I am having a similar problem on r8703 forward, where LiveTV brings up the There has been a problem displaying video' message. This is on a system where XvMc? support is compiled in, but it is not selected as I have a matrox G400 Videocard on that machine atthe moment. I am not using deinterlacing of any kind.

comment:18 Changed 14 years ago by danielk

Status: newassigned

TimJordan?, the logs confirm my suspicion. A new video output is being created before destroying the old one, if you don't have the additional resources things go boom.

I'll look at this today.

Changed 14 years ago by danielk

Attachment: 1122-fix-v2.patch added

Possible fix for EPIA XvMC

comment:19 Changed 14 years ago by danielk

Can someone with an EPIA setup test the patch I just attached?

If it doesn't work I'd be interested in the logs from "mythfrontend -v playback".

comment:20 Changed 14 years ago by John

afraid this doesnt fix my problem.

comment:21 Changed 14 years ago by john

Tracked the cause of my problem down. Rolling back the changes to livetvchain.cpp (svn update -r 8702 libs/libmythtv/livetvchain.cpp) on current svn r8745 fixes my problems. There seems to be some residual prebuffer pauses, but no hard failures. Do you want me to open a diffent ticket?

comment:22 Changed 14 years ago by anonymous

John, that is no fix. If you changed between two different cards you would still experience this problem after reverting that change, you would also experience segfaults on resolution changes; which is what that commit fixes.

Please provide the log I requested so that I can fix this problem.

Changed 14 years ago by TimJordan

Attachment: mythfrontend.2.log added

comment:23 Changed 14 years ago by TimJordan

This is the latest svn with the patch applied.

Regards

Tim

Changed 14 years ago by danielk

Attachment: 1122-fix-v3.patch added

adds some debugging to v2 of the patch

comment:24 Changed 14 years ago by danielk

Tim, please send me the same log from v3 of the patch. It adds some debugging where things seem to go wrong in your log.

comment:25 Changed 14 years ago by danielk

Resolution: fixed
Status: assignedclosed

(In [8755]) Fixes #1122.

This fixes the bug in the original logs posted with this ticket.

There appear to be more problems with XvMC in LiveTV mode, perhaps related to the problems reported in #774.

Changed 14 years ago by danielk

Attachment: 1122-fix-v4.patch added

Update of v4 to apply to current SVN

Changed 14 years ago by TimJordan

Attachment: mythfrontend.3.log added

latest svn with v4 patch applied

comment:26 Changed 14 years ago by TimJordan

Resolution: fixed
Status: closedreopened

The video element is fixed as in it now displays video, But it stutters a lot, the log shows lots of out of sync frames which make it unwatchable. Should this be a different ticket? It works fine using non xvmc btw.

Regards

Tim

Changed 14 years ago by john

Attachment: svn8759.log added

UK-DVB_T mythfrontend -v playback

comment:27 Changed 14 years ago by john

mythfrontend -v playback log. This shows the result of entering live TV, starting on chanid 1001 UK DVB-T (which is BBC1 on my system) which fails, changing to a dvb-s card (which works) and then back to the original UK DVB-T by selecting chanid 1004 (channel4). One succesfully opened a channel on the DVB-T card I seem to be able to switch back and forward between "working" and "failing" channels. As long as I finally leave LiveTV on a "working" channel, so it is the start channel for the next visit, then I can get back in.

comment:28 Changed 14 years ago by danielk

Resolution: fixed
Status: reopenedclosed

TimJordan?, you seem to be experiencing the classic symptoms of #774.

John Whitear, you are experiencing something else entirely. Can you e-mail me match backend and frontend logs with 'mythbackend -v record,channel' and 'mythfrontend -v playback' (repeating the same procedure), using the latest SVN? I don't know if this is described by one of the existing tickets like #971, or is something new. Looking at those logs might help.

comment:29 Changed 14 years ago by rob.r@…

I can cofirm on my setup that xvmc is back, but I am now seeing the same thing as TimJordan?. Video is there but looks like it's in slow motion. It worked fine in 8969.

comment:30 Changed 14 years ago by rob.r@…

Sorry, dislexic on the version, it worked fine in 8696. I don't think SVN can pull versions in from the future yet. ;)

comment:31 Changed 14 years ago by Jon Whitear

Daniel, updating to 8755 fixed my problem. Your fix for the LCD locking also seems to have reduced (if not eliminated) the number of frontend segfaults I've been getting. Updating to 8769 has cleared up a lot of audio stuttering, too. Thanks.

Note: See TracTickets for help on using tickets.