Opened 13 years ago

Closed 12 years ago

#1123 closed defect (duplicate)

Edit markers are not being placed correctly, SVN 8729

Reported by: Robert Kulagowski Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Running SVN 8729. Watch a recording, then enter edit mode by pressing "e".

Import the commercial cutlist by pressing "z".

The bar then changes color indicating program and commercial blocks, however the graphical "markers" are incorrectly positioned on the horizontal axis.

This is using GANT and Retro.

Chris Pinkham mentioned in IRC that he's seeing it as well with current SVN, but I don't know what theme he's running.

Attachments (3)

RetroEdit.jpg (27.1 KB) - added by thomas@… 13 years ago.
RetroEdit.2.jpg (27.1 KB) - added by thomas@… 13 years ago.
Editing using the Retro theme
RetroEditNoOverscan.jpg (27.1 KB) - added by thomas@… 13 years ago.
Editing with no overscan

Download all attachments as: .zip

Change History (11)

comment:1 Changed 13 years ago by beerd

I also see the same behaviour using the MythCenter? theme. Also using latest SVN

comment:2 Changed 13 years ago by cpinkham

Resolution: fixed
Status: newclosed

(In [8739]) This seems to fix the issues with the edit arrow markers appearing at the wrong position on the OSD. I tested this on four different OSD themes and it appears to fix things up correctly. Closes #1123. If someone still sees this occurring, reopen the ticket, let me know what OSD theme you're using, and attach a screenshot.

comment:3 Changed 13 years ago by thomas@…

Resolution: fixed
Status: closedreopened

I am seeing this problem using 0.20 and Retro theme. Attaching screenshot.

Changed 13 years ago by thomas@…

Attachment: RetroEdit.jpg added

Changed 13 years ago by thomas@…

Attachment: RetroEdit.2.jpg added

Editing using the Retro theme

comment:4 Changed 13 years ago by Janne <janne-mythtv@…>

If you're using overscan, the patch in #2163 should fix it.

comment:5 Changed 13 years ago by thomas@…

Version: 0.20

Yes, I had horizontal overscan +1%. If I set this to 0, then the markers are OK with Titivillus-OSD, but not with Retro-OSD. The start markers there are OK then, but the end markers are still off. Attaching new screenshot.

Changed 13 years ago by thomas@…

Attachment: RetroEditNoOverscan.jpg added

Editing with no overscan

comment:6 Changed 13 years ago by Janne <janne-mythtv@…>

sigh, yes. they are even off with my patch from #2163. I suspect that it is an issue with the edit mark picture.

comment:7 Changed 13 years ago by Isaac Richards

Priority: majorminor

comment:8 Changed 12 years ago by Janne Grunau

Resolution: duplicate
Status: reopenedclosed

duplicate of #2163

Note: See TracTickets for help on using tickets.