Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 18 months ago

Closed 13 months ago

Last modified 13 months ago

#11231 closed Bug Report - General (fixed)

Recording Group Password Does Not Work With Always Prompt For Initial Group Filter Enabled

Reported by: nospam312@… Owned by: stuartm
Priority: minor Milestone: 0.26.1
Component: MythTV - General Version: 0.26-fixes
Severity: medium Keywords: recording group password filter
Cc: Ticket locked: no

Description

I have password protected some Recording Groups but it does not appear
to accept the correct password even though I am using the correct
password?

The only method I can get access back to the recording group is to
clear the password by removing it from the recgrouppassword table.

You must enable Setup - Video - Playback - 5/8 Always Prompt For
Initial Group Filter to reproduce the problem.

In Watch Recordings select a Recording Group like All
Programmes press m choose Change Group Password enter a password. Try
to access All Programmes, enter the correct password and it does not
work.

If I disable the Prompt For Initial Filter the password works fine.

Further details on the following thread and confirmation of other people able to reproduce.

http://www.gossamer-threads.com/lists/mythtv/users/532936#532936

Using Mythbuntu 12.04, MythTV 0.26fixes, Mythbuntu Theme

Thanks

Attachments (0)

Change History (3)

comment:1 Changed 15 months ago by stuartm

  • Milestone changed from unknown to 0.26.1
  • Owner set to stuartm
  • Status changed from new to accepted

comment:2 Changed 13 months ago by David Engel <dengel@…>

  • Resolution set to fixed
  • Status changed from accepted to closed

In dfa05cde448a660ec2b10f3f0bb4f1c5cb3c3e42/mythtv:

Change PlaybackBox? group and password popup handling to be more sane.

If an invalid password is entered, the password popup is reshown. If
the password popup is aborted and was entered from the group popup or
is the initial group, the group popup is reshown. If the group popup
is aborted and was entered because of the QueryInitialFilter? setting,
the PlaybackBox? screen is closed.

Fixed #11231

comment:3 Changed 13 months ago by David Engel <dengel@…>

In ee98ece5de4b0e12079c70e06172161c0937bc95/mythtv:

Change PlaybackBox? group and password popup handling to be more sane.

Backport from master to fixes/0.26.

If an invalid password is entered, the password popup is reshown. If
the password popup is aborted and was entered from the group popup or
is the initial group, the group popup is reshown. If the group popup
is aborted and was entered because of the QueryInitialFilter? setting,
the PlaybackBox? screen is closed.

Refs #11231

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.