Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#11235 closed Bug Report - General (Works for me)

LiveTV stops playing when another computer logs in

Reported by: Daniel Ellis <mail@…> Owned by: JYA
Priority: minor Milestone: unknown
Component: MythTV - Airplay Version: 0.26-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

LiveTV or recordings will stop playing and will exit to the main menu when another computer on the LAN logs in (or comes out of standby), if the remote computer has PulseAudio? and the user has selected "Make discoverable Apple AirTunes? sound devices available locally" in the preferences.

So for example, when I login to my LinuxMint? laptop, or it comes out of standby, some multicast discovery packets are sent, which MythTV attempts to handle, and MythTV will stop playing the current program and exit to the main menu.

Attached is the mythfrontend console log, which you can see RAOP trying to treat the discovery as a new connection.

Also attached is a packet capture made from the MythTV frontend machine. For purposes of reading the packet capture, here are the machine details:-

Barney 192.168.10.5 - MythTV frontend/backend Wiggum 192.168.10.138 - LinuxMint? 13 laptop with PulseAudio?

It's not a serious issue for me now that I have located the issue and disabled the PulseAudio? setting which was triggering the problem. But it was very confusing at first so hopefully this bug report may save someone from this strange occurrence!

Attachments (2)

mythfrontend.txt (2.3 KB) - added by Daniel Ellis <mail@…> 7 years ago.
mythfrontend console log
raop-trace.pcap (11.7 KB) - added by Daniel Ellis <mail@…> 7 years ago.
Trace of the MDNS/RAOP messages which cause the issue

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Daniel Ellis <mail@…>

Attachment: mythfrontend.txt added

mythfrontend console log

Changed 7 years ago by Daniel Ellis <mail@…>

Attachment: raop-trace.pcap added

Trace of the MDNS/RAOP messages which cause the issue

comment:1 Changed 6 years ago by JYA

Resolution: Works for me
Status: newclosed

Can't reproduce the issue...

current Playback is interrupted, only if the remote computer is attempting to actually play something; not when it's simply connecting to the AirPlay? server (like iTunes does)

Please try again with 0.27.

comment:2 Changed 6 years ago by Daniel Ellis <mail@…>

This still happens with MythTV 0.27 from LinuxMint? 15. However the same problem occurs with XBMC 13, so maybe this is actually a problem with PulseAudio? initiating some kind of dummy connection when it shouldn't.

Note: See TracTickets for help on using tickets.