Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 17 months ago

Closed 17 months ago

Last modified 15 months ago

#11240 closed Bug Report - General (fixed)

Build fail with --disable-ceton

Reported by: gary.buhrmaster@… Owned by: danielk
Priority: minor Milestone: 0.27
Component: MythTV - configure script Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Master fails to build when --disable-ceton is used with configure. Ithe relevant line that reports the failure is:

g++  -o mythavtest main.o commandlineparser.o     -L../../libs/libmyth -L../../libs/libmythtv -L../../external/FFmpeg/libavutil -L../../external/FFmpeg/libavcodec -L../../external/FFmpeg/libavformat -L../../external/FFmpeg/libswscale -L../../libs/libmythbase -L../../libs/libmythui -L../../libs/libmythupnp -L../../libs/libmythmetadata -L../../libs/libmythservicecontracts -L../../libs/libmythprotoserver -lmythswscale -lmythavformat -lmythavcodec -lmythavutil -lmythtv-0.27 -lmythupnp-0.27 -lmythbase-0.27 -lmythui-0.27 -lmyth-0.27 -lmythmetadata-0.27 -lmythservicecontracts-0.27 -lmythprotoserver-0.27 -L../../libs/libmythfreemheg -lmythfreemheg-0.27 -L../../libs/libmythhdhomerun -lmythhdhomerun-0.27 -lXext -lXinerama -lXxf86vm -lXv -lXrandr -lX11 -lxml2 -ldns_sd -lcrypto -lass -lmp3lame -lpulse -lasound -lva -lm -luuid -pthread -lbz2 -lz -lrt -ldl -lfreetype -lraw1394 -liec61883 -lavc1394 -lrom1394 -L/usr/X11R6/lib -L/home/gtb/devel/mythtv/mythtv/mythtv/external/zeromq/src/.libs -lmythzmq -L/home/gtb/devel/mythtv/mythtv/mythtv/external/nzmqt/src -lmythnzmqt -L/home/gtb/devel/mythtv/mythtv/mythtv/external/qjson/lib -lmythqjson -L/usr/local/lib -L/usr/lib64 -lpthread -lGL -lQtSql -lQtXml -lQtOpenGL -lQtGui -lQtNetwork -lQtCore 
../../libs/libmythtv/libmythtv-0.27.so: undefined reference to `CetonRTSP::Play()'
../../libs/libmythtv/libmythtv-0.27.so: undefined reference to `CetonRTSP::CetonRTSP(QUrl const&)'
../../libs/libmythtv/libmythtv-0.27.so: undefined reference to `CetonRTSP::Describe()'
../../libs/libmythtv/libmythtv-0.27.so: undefined reference to `CetonRTSP::GetOptions(QStringList&)'
../../libs/libmythtv/libmythtv-0.27.so: undefined reference to `CetonRTSP::Teardown()'
../../libs/libmythtv/libmythtv-0.27.so: undefined reference to `CetonRTSP::Setup(unsigned short, unsigned short)'
collect2: error: ld returned 1 exit status
make[2]: *** [mythavtest] Error 1
make[2]: Leaving directory `/local/home/gtb/devel/mythtv/mythtv/mythtv/programs/mythavtest'
make[1]: *** [sub-mythavtest-make_default] Error 2
make[1]: Leaving directory `/local/home/gtb/devel/mythtv/mythtv/mythtv/programs'
make: *** [programs] Error 2

I think the issue is that the iptvrecorder depends on the CetonRTSP codes, but libmythtv.pro does not build the codes when --disable-ceton is specified. And before you ask, no, I would not normally configure with --disable-ceton, and have no reason to do so in general, but I was testing something completely different, and ran into this bug. I suspect the answer is that the rtsp code is generally useful, and should not be disabled by --disable-ceton (perhaps should not have the ceton name in it) but I will let the people smarter than I determine the best path. Thanks.

Attachments (0)

Change History (3)

comment:1 Changed 17 months ago by danielk

  • Owner changed from beirdo to danielk
  • Status changed from new to accepted

Yep, should be renamed and made available more generally.

comment:2 Changed 17 months ago by Daniel Thor Kristjansson <danielk@…>

  • Resolution set to fixed
  • Status changed from accepted to closed

In f831b99eb8f03e5b07ba687355d7823fefbfe33d/mythtv:

Fixes #11240. Always Build CetonRTSP.

This is currently used for all IPTV recorders. Will be replaced by a more
generic RTSP class in the near future.

comment:3 Changed 15 months ago by wagnerrp

  • Milestone changed from unknown to 0.27

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.