Opened 13 years ago

Closed 13 years ago

#1125 closed enhancement (invalid)

Request to allow mythfilldatabase to use single XML source for multiple differing input sources

Reported by: knowledgejunkie@… Owned by: Isaac Richards
Priority: minor Milestone: 0.20
Component: mythtv Version:
Severity: low Keywords: mythfilldatabase XML XMLTV
Cc: Ticket locked: no

Description

(Perhaps this only applies to XMLTV-based grabbers)

Currently I have 3 video sources on 5 cards (digital cable, digital terrestrial [DVB-T], and analogue terrestrial). All sources use the uk_rt XMLTV grabber for listings data. I currently have to run the grabber 3 times, once for each source with own config file, and run mythfilldatabase from cron on each of the 3 XML files produced. (The digital cable video source contains _nearly_ all channels found on the other 2 sources, so is almost a super-set of the 3 sources itself.)

I would like the ability to run a single cron job for the grabber, and a single cron job for MFDB. The grabber xmltv configuration file would contain all of the XMLTV IDs for all of the unique channels on all sources. This would allow a 'super-set' of listings data to be created in a single file. MFDB would then be run on this single data file and would update listings data on all channels where there is a XMLTVID match. This could be achieved by passing a CSV-list of sourceids to MFDB at runtime.

Herein lies the issue - I can easily get a single XML file containing all of the listings data I want, but MFDB will add new instances of channels on sources that do not contain channels matching all XMLTVIDs found in the source file. This intended behaviour therefore should be coupled with the abiity for MFDB to _not_ automatically create new channel instances on sources where not all XMLTVIDs are matched (something like --dont-add-channels).

It seems inefficient (to me) to have run MFDB 3 times to import the exact same data onto 3 different sources having common channels, and also to have to hit the BBC's XML listings each time (even though I cache the listings data through Perl's httpcache).

I know from the mythtv-users list that the auto creation of channels found in the source data but not in the DB also causes undue frustration, and I would relish seeing this as a separate run-time option for MFDB.

Nick

Change History (1)

comment:1 Changed 13 years ago by anonymous

Resolution: invalid
Status: newclosed

Feature request without patch.

Read the TicketHowTo, Trac is not a wishlist.

Note: See TracTickets for help on using tickets.