Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11262 closed Bug Report - Hang/Deadlock (Duplicate)

Analog LiveTV practically not usable any more

Reported by: jaglover@… Owned by: Jim Stichnoth
Priority: minor Milestone: 0.26.1
Component: MythTV - General Version: 0.26-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have been using MythTV since 0.21. Sorry if it sounds like a rant, but with every new version analog livetv function goes gradually worse. With 0.25 I was still able to watch a certain channel although I couldn't change it without switching to a digital channel in between. Now with 0.26 every time a new show starts (on the same channel) mythtv creates a zero-byte file and goes to the menu screen. I logged backend and frontend terminal outputs when trying to change channels, attached.

Attachments (5)

frontlog (45.3 KB) - added by jaglover@… 7 years ago.
Frontend terminal output
backlog (8.6 KB) - added by jaglover@… 7 years ago.
Backend terminal output
frontlog_after_patch (45.1 KB) - added by jaglover@… 7 years ago.
Frontend log after patch
backlog.2 (88.3 KB) - added by jaglover@… 7 years ago.
Backend log with -v channel,record
backlog.3 (30.2 KB) - added by Saul <jaglover@…> 7 years ago.
Backend log with -v channel,record - with poll time 5000 ms

Download all attachments as: .zip

Change History (25)

Changed 7 years ago by jaglover@…

Attachment: frontlog added

Frontend terminal output

Changed 7 years ago by jaglover@…

Attachment: backlog added

Backend terminal output

comment:1 Changed 7 years ago by jpoet

The may be a dupe of #10732. Are you able to test the patch applied to that ticket?

Last edited 7 years ago by jpoet (previous) (diff)

Changed 7 years ago by jaglover@…

Attachment: frontlog_after_patch added

Frontend log after patch

comment:2 Changed 7 years ago by jaglover@…

Nope, still same, new log attached just in case.

comment:3 Changed 7 years ago by jaglover@…

Tried one more time, with all compiler flags disabled and ccache disabled (I'm on Gentoo). No cigar. Will try with gcc-4.6.3 and report back if there is any improvement.

comment:4 Changed 7 years ago by jaglover@…

Also tried with vanilla kernel 3.6.8. No improvement.

comment:5 Changed 7 years ago by jpoet

Just to clarify, it works until it is time for the next program in the guide to start? What kind of capture cards do you have?

Please attach new backend logs with "-v channel,record".

comment:6 Changed 7 years ago by jaglover@…

Still running patched version (as suggested above), built with gcc-4.6.3, vanilla kernel 3.6.8. The card is Hauppauge 2250, using analog side only, video1 and video2. There is also a framegrabber card in this box (HD-5500, /dev/video0) which is not set up for use with MythTV. In the log I attached new program starts 18:00. Thanks.

Changed 7 years ago by jaglover@…

Attachment: backlog.2 added

Backend log with -v channel,record

comment:7 Changed 7 years ago by jaglover@…

Correction, new program starts 18:30.

comment:8 Changed 7 years ago by jpoet

Can you try editing libs/libmythtv/recorders/DeviceReadBuffer.cpp . Change line 33 from:

max_poll_wait(2500 /*ms*/),

to

max_poll_wait(5000 /*ms*/),

And see if that helps? That will give the poll twice as long before it aborts. It should get rid of the poll errors in your logs, and might fix the problem.

comment:9 Changed 7 years ago by Saul <jaglover@…>

Now frontend is giving me "Error opening jump file" error and won't play at all, although the file mentioned in log is created and is bigger than zero bytes. New log attached.

Changed 7 years ago by Saul <jaglover@…>

Attachment: backlog.3 added

Backend log with -v channel,record - with poll time 5000 ms

comment:10 Changed 7 years ago by jaglover@…

Funny, I tried to increase it to 2550 ms, now I get (everything else is still same - no improvement)

2012-12-02 06:49:55.680680 W DevRdB(/dev/video2): Poll took an unusually long time 2552 ms 2012-12-02 06:49:58.238342 W DevRdB(/dev/video2): Poll took an unusually long time 2553 ms 2012-12-02 06:50:00.796033 W DevRdB(/dev/video2): Poll took an unusually long time 2553 ms 2012-12-02 06:50:03.352391 W DevRdB(/dev/video2): Poll took an unusually long time 2552 ms

comment:11 Changed 7 years ago by stuartm

Are you using the very latest version of 0.26-fixes? It's not clear from your logs as your packager isn't using a helpful version string.

comment:12 Changed 7 years ago by jaglover@…

I was using the one Gentoo ebuild pulls in. A few weeks old. Just did a git pull, built and installed. Patch-wise I'm back to square one, plain sources from git repo. Unfortunately, it's all same. BTW, frontend blesses me mostly with "Video buffering failed too many times", but sometimes I also get "Error opening jump file". Versatile!

comment:13 Changed 7 years ago by skd5aner <skd5aner@…>

Possible dupe of #11229 and/or #11211 -

Yes, lots of people having the same problem, let's keep everything together...

comment:14 Changed 7 years ago by straximus@…

Also a dupe of #11175.

comment:15 Changed 7 years ago by jlatz@…

Came across this as I was trying to diagnose why analog recently completely failed on my machine - I have two cards: one HVR-1600, a second HVR-2250.

I just figured out that somehow - I know not how - the default frequency table had been reset from us-cable to us-bcast. Setting it back fixed everything.

Run through mythtv-setup and see what frequency table you're using for analog, can't hurt...

comment:16 Changed 7 years ago by jaglover@…

Nope, it still can record. Just no live TV. Actually, I was thinking maybe it has something to do with my hardware. So I built a brand new dedicated backend. But things got even worse. With both BE and FE in the same box I was able to watch recordings in process. Now when I try to do that both BE and FE crash. I'm not attaching any logs because I do not think anybody is interested.

comment:17 Changed 7 years ago by straximus@…

The Feb 3rd commit to 0.26-fixes for this issue appears to have resolved it for me. I just changed analog channels over a dozen times without incident. I've also watched one program rollover into the next without issue.

Thanks!

comment:18 Changed 7 years ago by Jim Stichnoth

Milestone: unknown0.26.1
Owner: set to Jim Stichnoth
Priority: majorminor
Status: newaccepted

comment:19 Changed 7 years ago by Jim Stichnoth

Resolution: Duplicate
Status: acceptedclosed

Closing as a duplicate of #11211, which was fixed in a1b9b1f94a774710443637de034c661618e5baa3.

Note that this fixes a specific regression introduced in 0.26. Live TV bugs present in 0.25 may still be lurking.

jaglover, please reopen if you're still seeing the same problem.

comment:20 Changed 7 years ago by jaglover@…

Yes, this issue is gone. Thank you! Although the liveTV issue that started long time ago (0.24 methinks) is still present, I get occasional "Error opening jump program file".

Note: See TracTickets for help on using tickets.