Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11270 closed Bug Report - General (Invalid)

php-5.4.8-1.fc17.x86_64, ticket 10504, php doesn't work

Reported by: udovdh@… Owned by: Rob Smith
Priority: trivial Milestone: unknown
Component: Plugin - MythWeb Version: 0.26-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Mythweb stopped working when upgrading to 0.25.x. A solution was promised in 0.26.1 in ticket 10504. That ticket was changed, essentially no code was changed when that happened, and an upgrade to 0.26.0.1 was suggested. So I did and I found no change w.r.t. the mythweb problem(s). Question is if I see the same issues as in 10504 or not. I see in the httpd error_log: PHP Warning: Unknown: function '0' not found or invalid function name in Unknown on line 0

I also see 500 errors when trying to open the mythweb homepage. When I apply the tree patches from ticket 10504 stuff behaves better.

The thing that does NOT work is the recorded programs screen. at the top of the screen this is printed:

Warning at /usr/share/mythweb/modules/tv/recorded.php, line 193: !NoTrans: gmp_add(): Unable to convert variable to GMP - wrong type!!

Warning at /usr/share/mythweb/modules/tv/recorded.php, line 194: !NoTrans: gmp_add(): Unable to convert variable to GMP - wrong type!!

Warning at /usr/share/mythweb/modules/_shared/tmpl/default/header.php, line 16: !NoTrans: Cannot modify header information - headers already sent by (output started at /usr/share/mythweb/includes/errors.php:150)!!

I get a pop-up like message saying: Warning: No matching programs found. Showing all programs.

When I click OK I can select a group, but the groups are shown as numbers of 10 positions. A selection does not show a program. When I select a program under Show recordings I get the pop-up like message saying: Warning: No matching programs found. Showing all programs.

I use the packaging solution from git to build the rpms. mythweb is installed in /usr/share/mythweb/mythweb instead of /usr/share/mythweb/ so I copy stuff there. Then I replace the MythBackend?.php from php-MythTV and also put MythBackend?.php in include. After applying the three patches from 10504 stuff starts to work.

Change History (9)

comment:1 Changed 6 years ago by Kenni Lund [kenni a kelu dot dk]

Component: MythTV - GeneralPlugin - MythWeb
Owner: set to Rob Smith
Priority: majortrivial

Udo, I'm having a very hard time understanding your ticket. Are you saying that you need to apply the three patches which Dave uploaded to #10504 in order to make Mythweb work in 0.26-fixes? That doesn't make any sense, as these changes are already in 0.26-fixes. It sounds like you're still using Mythweb 0.25.

comment:2 Changed 6 years ago by Kenni Lund [kenni a kelu dot dk]

...and/or MythTV 0.25.

comment:3 Changed 6 years ago by udovdh@…

On 2012-12-03 18:43, MythTV wrote:

Udo, I'm having a very hard time understanding your ticket. Are you saying that you need to apply the three patches which Dave uploaded to #10504 in order to make Mythweb work in 0.26-fixes? That doesn't make any sense, as these changes are already in 0.26-fixes. It sounds like you're still using Mythweb 0.25.

# mythbackend --version Please attach all output as a file in bug reports. MythTV Version : v0.26.0-53-gb28041a MythTV Branch : master Network Protocol : 75 Library API : 0.26.20120822-1 QT Version : 4.8.3 Options compiled in:

linux release use_hidesyms using_alsa using_jack using_oss using_pulse

using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv using_ivtv using_joystick_menu using_libcrypto using_libfftw3 using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_live using_mheg using_libxml2

But what about the mythweb version? Backend status page does not work. So only I can say: # rpm -q mythweb mythweb-0.26.0-0.1.git.1.fc17.x86_64

Anything else to confirm?

Did I misconfigure the rpm build script from teh packaging git repo? Or is a bug in there?

From mythweb.spec:

# Version/Release? info Version: 0.26.0 %if "%{branch}" == "master" Release: 0.1.git.%{_gitrev}%{?dist} %else Release: 1%{?dist} %endif

# The primary license is GPLv2+, but bits are borrowed from a number of # projects... For a breakdown of the licensing, see PACKAGE-LICENSING. License: GPLv2+ and LGPLv2+ and LGPLv2 and (GPLv2 or QPL) and (GPLv2+ or LGPLv2+)

Requires: php-MythTV >= %{version} Requires: httpd >= 1.3.26 Requires: php >= 5.3 Requires: php-mysql Requires: php-process

################################################################################

Source: http://www.mythtv.org/mc/mythweb-%{version}.tar.bz2 Source401: mythweb.conf

comment:4 Changed 6 years ago by Kenni Lund [kenni a kelu dot dk]

Resolution: Invalid
Status: newclosed

Something is wrong with your setup for sure, your output from mythbackend doesn't make any sense, as the hash is from the 0.26-fixes branch while the branch says "Master" (which is pre0.27).

Too many indications that these issues are originating from user configuration errors rather than bugs in 0.26-fixes.

You shouldn't even be able to apply at least two of these three patches, as the code in question is already in the codebase you're trying to patch.

Please search for help on the mythtv-users mailing list.

comment:5 Changed 6 years ago by udovdh@…

I need more leads to confirm your finding. Did you see where the mythweb.spec gets the source? How much can go wrong there? At what database version should the database be after 0.26-fixes? Git for mythtv is at fixes/0.26, not master. Please let me know where 0.26-fixes should be (git hash) so I can verify the local git copy.

comment:6 Changed 6 years ago by udovdh@…

Both my local mythtv tree and a fresh clone give: # git describe v0.26.0-53-gb28041a So the build script is aware of the version. Build script is from https://github.com/MythTV/packaging. That script generates the mythweb rpm from git.

comment:7 Changed 6 years ago by udovdh@…

After checking out mythweb using the info from http://code.mythtv.org/trac and copying that in /usr/share/mythweb I still get: PHP Warning: Unknown: function '0' not found or invalid function name in Unknown on line 0, referer: http://recorder/mythweb/tv/upcoming

comment:8 Changed 6 years ago by udovdh@…

After getting mybackend up and running again the errors in mythweb persist. Upcoming recordings screen shows an empty list. Each refresh of that screen gives 'PHP Warning: Unknown: function '0' not found or invalid function name in Unknown on line 0, referer: http://recorder/mythweb/' in httpd's error_log. The backend status screenw works.

comment:9 Changed 6 years ago by udovdh@…

When I change the comobox from All Titles to a specific programme, the occurrences of that programme are shown. When I go back to the All Titles selection suddenly all titles are displayed. (they weren't before this moment) What is the cause?

Note: See TracTickets for help on using tickets.