Opened 7 years ago

Closed 7 years ago

#11308 closed Bug Report - General (Fixed)

Skipping when playing from video library does not work

Reported by: Ronny Standtke <ronny.standtke@…> Owned by: Jim Stichnoth
Priority: minor Milestone: 0.27
Component: MythTV - Video Playback Version: 0.26-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When playing live tv or recordings, skipping forward and backward works like expected. So far so good...

Unfortunately, when watching videos from the video library, skipping is more or less broken: whatever button I press (left, right, up, down) the video just skips forward for some seconds. This way it is impossible to jump back for some seconds (because e.g. you did not understand a part of a dialog) or skip forward longer time spans (because e.g. you have already seen the first half of a movie). This is a regression because it worked perfectly until I upgraded from v0.25 to v0.26.

This is such a severe limitation for me that I stopped using mythtv for video playback and switched back to external players.

Attachments (1)

myth.log (43.4 KB) - added by Ronny Standtke <ronny.standtke@…> 7 years ago.
log file from "mythfrontend -v playback"

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by Jim Stichnoth

Owner: set to Jim Stichnoth
Status: newaccepted

comment:2 Changed 7 years ago by Jim Stichnoth

Status: acceptedinfoneeded

This has nothing to do with Video Library, but rather with the video file itself. Please attach a complete log file from "mythfrontend -v playback" that demonstrates the problem.

Changed 7 years ago by Ronny Standtke <ronny.standtke@…>

Attachment: myth.log added

log file from "mythfrontend -v playback"

comment:3 Changed 7 years ago by Ronny Standtke <ronny.standtke@…>

I just run:

$ export LC_ALL=C
$ mythfrontend -v playback > myth.log

I tried to view a video but, unfortunately, playback failed. Another video started, I tried skipping forward and backward a few times (but it failed as always). I don't know if the log file clearly demonstrates the problem...

Please let me know if I can do anything else in assisting to fix this bug (besides coding).

PS: Happy new year!

comment:4 Changed 7 years ago by Jim Stichnoth

Milestone: unknown0.27
Resolution: Fixed
Status: infoneededclosed

I'm optimistically marked this as fixed in Master and the future 0.27 release as a result of the #10104 related changes. Please reopen if this turns out not to be the case.

In the meantime, seeking should work correctly for a non-Matroska video if you manually rebuild the seektable:

mythcommflag --rebuild --video path/to/my/video.avi

Note that mythcommflag is a bit temperamental about pathnames, e.g. absolute versus relative to the storage group directory, so please seek help on the mythtv-users list if this fails to work.

Note: See TracTickets for help on using tickets.