Opened 6 years ago

Closed 6 years ago

#11359 closed Bug Report - General (Duplicate)

Record group password not recognized

Reported by: tom.oli@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.26-fixes
Severity: medium Keywords: Record group password frontend
Cc: Ticket locked: no

Description

Set a password for a record group, for instance by phpMyAdmin. Select this record group in frontend. You are prompted for a password. Type in the password and switch to OK. Prompt disappears and nothing else happens. Record group is not entered.

Set it to major because it disallows parental control of recordings. I can enter record groups only when I unset password in recgrouppassword table.

Change History (8)

comment:1 Changed 6 years ago by tom.oli@…

Please set Milestone to 0.26.1. Don't know how to modify it after ticket is created.

comment:2 Changed 6 years ago by Raymond Wagner

Priority: majorminor

comment:3 Changed 6 years ago by stuartm

Status: newinfoneeded_new

This works for me. How are you entering the password?

P.S. You should be setting the password through mythfrontend, MENU x 2 - Change Group Password

comment:4 Changed 6 years ago by nospam312@…

This sounds like it could be related to the problem I reported on #11231. Would be great if a fix could be put in 026 fixes. Perhaps Tom could indicate if he also has the Prompt For Group Filter option turned on? Thanks.

comment:5 in reply to:  3 Changed 6 years ago by tom.oli@…

Replying to stuartm:

P.S. You should be setting the password through mythfrontend, MENU x 2 - Change Group Password

Did it this way. Same result as described above. Both setting methods lead to the problem, setting in FE and by phpMyAdmin in recgrouppaswword table.

comment:6 in reply to:  4 Changed 6 years ago by tom.oli@…

Replying to nospam312@…:

Perhaps Tom could indicate if he also has the Prompt For Group Filter option turned on? Thanks.

Yes it is on. If I'd like to enter records, I am first prompted for the record groups. I used to have password-protected and free accessible groups here. Currently all groups have to be free accessible.

comment:7 Changed 6 years ago by tom.oli@…

It works, if I disable "Prompt For Group Filter" option. Then I can cycle through the groups. If a password protected group is to be opened I am asked for the password, I enter it and it works.

However, cycling is annoying, because the password prompts disturb a fluent cycling. Selecting group from the group filter list is preferred. But then the password input doesn't work ...

comment:8 Changed 6 years ago by gigem

Resolution: Duplicate
Status: infoneeded_newclosed

This is a duplicate of #11231.

Note: See TracTickets for help on using tickets.