Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 15 months ago

Closed 10 months ago

Last modified 10 months ago

#11376 closed Bug Report - General (fixed)

LOTR: The Two Towers ISO keep switching to English language

Reported by: stefano.ceccherini@… Owned by: stuartm
Priority: minor Milestone: 0.27
Component: MythTV - DVD Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have created an iso from the Lord of the Rings: The Two Towers DVD (Italian version).
The playback always resets to the English audio track, no matter if I select the italian track in the DVD menu or with the OSD. When I use the OSD to select the italian track, it works for the current scene, but as soon as the playback goes to the next chapter, it resets to English again.
The iso is on a mythtv backend using storage groups.
Note that "LOTR: The Fellowship of the Ring" doesn't have this problem (nor many other DVDs I have converted to ISO).
Which logs can I provide to help with this ?

Attachments (1)

0001-Fix-filtering-sorting-and-selection-of-DVD-audio-str.patch (14.6 KB) - added by peper03@… 11 months ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 15 months ago by stichnot

This could be a dup of #9429. Even though #9429 and its attached patch deal with subtitle tracks rather than audio tracks, there may be the same fundamental issue of mapping between tracks and languages.

comment:2 Changed 15 months ago by stuartm

  • Milestone changed from unknown to 0.26.1
  • Owner set to stuartm
  • Status changed from new to accepted

comment:3 Changed 15 months ago by J.Pilk@…

Not directly relevant, but I've recently started using Project-X in -tots mode to cut recordings from DVB-T in the UK, yielding single video and audio output streams in a TS format that works with uPnP on my TV. VLC and mediainfo agree - wrongly - that the audio stream is in Deutsch/German?.

comment:4 Changed 14 months ago by peper03@…

Logs with -v playback --loglevel=debug would probably be best for starters.

Changed 11 months ago by peper03@…

comment:5 Changed 11 months ago by peper03@…

As suggested by stichnot, this appears to be the same conceptual issue as in #9429.
The attached patch filters out audio streams that are not mapped in the current program chain, which should prevent the mapping errors being encountered.

See also LangSPU_16x9.iso in stuartm's repository.

comment:6 Changed 10 months ago by Richard <peper03@…>

  • Resolution set to fixed
  • Status changed from accepted to closed

In 8bcef59e9c55e957b895623cf394162c5d6f541c/mythtv:

Fix filtering, sorting and selection of DVD audio streams when the mapping in a PGC is not 1:1, which was broken due to different functions/methods providing or requiring a physical stream ID, logical track number or logical index, with little consistency between them, and 'disabled' streams not being filtered out.

DVDRingBuffer now returns and expects an index into the PGC_AST_CTL table for all audio stream methods, with GetAudioTrackNum? now providing a mapping from physical stream ID to logical index.

The MythTV-specific change to vm_get_audio_stream in vm.c has been reverted as it didn't work as intended and the intended functionality is now in DVDRingBuffer::GetAudioTrackNum?.

Fixes #11376

comment:7 Changed 10 months ago by peper03

  • Milestone changed from 0.26.1 to 0.27
  • Version changed from 0.26-fixes to Master Head

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.