Opened 7 years ago

Closed 7 years ago

#11395 closed Bug Report - Crash (Duplicate)

mythlogserver crashes on timeout instead of cleanly quitting

Reported by: xdrcft@… Owned by: beirdo
Priority: minor Milestone: unknown
Component: MythTV - Mythlogserver Version: 0.26-fixes
Severity: medium Keywords: idleness shutdown
Cc: Ticket locked: no

Description

When mythlogserver is idle for 5 minutes, it logs the message "Shutting down because of idleness" and then crashes with a segment violation instead of exiting properly.

Attached is a crash report.

I'm running OS-X 10.7.5.

Attachments (1)

mythlogserver.crashlog (50.0 KB) - added by xdrcft@… 7 years ago.
mythlogserver crashlog

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by xdrcft@…

Attachment: mythlogserver.crashlog added

mythlogserver crashlog

comment:1 Changed 7 years ago by xdrcft@…

I should mention that I modified the 0.26-fixes source before building: I deleted the --daemon switch in the code where mythlogserver is invoked (in LoggerThread::launchLogServer(), which is in libmythbase/logging.cpp). I did that because mythlogserver seems to crash on launch with --daemon and to run OK when started without.

comment:2 Changed 7 years ago by xdrcft@…

A crash -- EXC_BAD_ACCESS (SIGSEGV) -- also occurs, instead of a clean exit, if I start mythlogserver from the command line and then immediately use Activity Monitor to Quit the process, which apparently sends a SIGTERM 15 signal.

dgktkr

comment:3 Changed 7 years ago by xdrcft@…

This ticket is a duplicate of #10924. A patch to fix the problem is given there.

dgktkr

comment:4 Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

Resolution: Duplicate
Status: newclosed

Duplicate of #10924.

Note: See TracTickets for help on using tickets.