Opened 6 years ago

Closed 6 years ago

#11403 closed Bug Report - General (Upstream Bug)

This is a variant of Ticket #10830 for the Hauppauge NOVA-TD Dual Tuner Diversity USB Stick

Reported by: anothersname@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - DVB Version: 0.25.1
Severity: medium Keywords: NOVA-TD, Elgato, 10830,
Cc: Ticket locked: no

Description

Ticket 10830 is also affecting the Hauppauge NOVA-TD Diversity Dual Tuner USB Stick.

While femon -H -ax allows me to at least get the device recognised in mythtv-setup I cannot get a proper lock while tuning consistently, sometimes it'll tune, other times not. This is not a device or driver issue as using the same device with no configuration I can tune into all channels on all muxes using VLC to drive it.

Can people who have used the femon trick previously please state whether they are also having to run femon when the backend is running or do they ONLY have to run femon for the mythtv-setup stage?

Thanks

Attachments (2)

mythtv-setup.log (149.8 KB) - added by anothersname@… 6 years ago.
mythtv-setup.log
mythbackend.log (609.1 KB) - added by anothersname@… 6 years ago.
mythbackend.log

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by anothersname@…

Sorry my bad.....

Version is 25.1 Fixes from the Ubunto repos.

comment:2 Changed 6 years ago by dekarl@…

Without backend logs around the time of the failure can only offer wild guesses. My guess is that you may have on-demand device opening enabled which might trigger the same bug.

It doesn't matter if VLC triggers the same kernel/driver bug as VLC may be using the device differently (not open/close in the same way, have a better work around for the bug, etc pp)

Changed 6 years ago by anothersname@…

Attachment: mythtv-setup.log added

mythtv-setup.log

Changed 6 years ago by anothersname@…

Attachment: mythbackend.log added

mythbackend.log

comment:3 Changed 6 years ago by anothersname@…

Since posting the original message I've had an EMail exchange with Juergen who wrote the original patch and he's advised me there's an updated patch in 3.6 that is probably delayed till 3.9 http://people.freebsd.org/~nox/tmp/ioctltst.c

It does appear to be in v4l git so I'll try it over the weekend and report back.

I think you can mark this as upstream but if you can leave it open till I check the new patch so at least people can see the status till 3.9 is released.

comment:4 Changed 6 years ago by anothersname@…

I can confirm that compiling V4L from git fixes this problem.

The current version of V4L on git is 3.9.

You can probably mark this as fixed although people may need to compile their own V4L before the fix filters down from upstream.

Thanks for the help.

comment:5 Changed 6 years ago by Kenni Lund [kenni a kelu dot dk]

Resolution: Upstream Bug
Status: newclosed
Version: Unspecified0.25.1
Note: See TracTickets for help on using tickets.