Opened 13 years ago

Closed 13 years ago

#1157 closed enhancement (fixed)

README changes for mythplugins, was: parts of, parts of mythplugins, installing in wrong directory

Reported by: mythtv.cvs@… Owned by: Isaac Richards
Priority: minor Milestone: 0.19
Component: mythtv Version:
Severity: low Keywords:
Cc: Ticket locked: no

Description (last modified by danielk)

I did a plain ./configure, qmake and make-> install with mythplugins. Most of them installed correctly, but quite a few did this:

cp -f "mythweather_es.qm" "/share/mythtv/i18n/" cp -f "mythvideo_it.qm" "/share/mythtv/i18n/" cp -f "libmythnews.so" "/lib/mythtv/plugins/libmythnews.so"

Some installed correctly. Parts of mythgallery for example, do this, and other parts install correctly...

Change History (4)

comment:1 Changed 13 years ago by danielk

Description: modified (diff)
Resolution: worksforme
Status: newclosed

Hmmm, I just tried this and it worked for me.

Did you install the same revision of MythTV before running ./configure for the plugins?

When you run "ls -l mythconfig.mak" does it say:

"mythconfig.mak -> /usr/local/include/mythtv/mythconfig.mak" ?

Is that the file just installed by MythTV, or is a link to a prior installation of MythTV elsewhere?

comment:2 Changed 13 years ago by anonymous

Resolution: worksforme
Severity: mediumlow
Status: closedreopened
Summary: parts of, parts of mythplugins, installing in wrong directoryREADME changes for mythplugins, was: parts of, parts of mythplugins, installing in wrong directory
Type: defectenhancement

I suggest adding text in the README, in the plugins package, that inidicates Myth must be compiled before doing _anything_.

Initially I compiled MythTV, but before I replaced my working/existing Myth, I wanted to make sure the plugins compiled correctly. I was concerned about compiling and installing Myth, then having a problem with the plugins, and then having to revert my Myth install back to a previous version. (NOTE: it would be quite nice if one could verify plugin success before installing Myth).

Anyhow, I read the README, which simply stated that I should simply do a configure followed by a qmake and then make. I did these things, only to find out that there were issues without Myth installed. At that point, I installed my new myth install, and proceeded with mythplugin....

This must be why mythconfig.mak was not there before, or from an older version. I suggest adding anything, something to the README to let users know about this gotcha.

I'm trying a fresh install of plugins, now, from a make distclean perspective. I'll report back...

comment:3 Changed 13 years ago by mythtv.cvs@…

Yes, the scenario above caused this issue. Plugins installed fine this time around.

comment:4 Changed 13 years ago by danielk

Resolution: fixed
Status: reopenedclosed

(In [8806]) Closes #1157.

Quick mention of need to install MythTV in README.

Note: See TracTickets for help on using tickets.