Opened 14 years ago

Closed 14 years ago

#1159 closed defect (fixed)

Mythfrontend seg faults when exiting live tv. Back trace attached.

Reported by: harley@… Owned by: danielk
Priority: minor Milestone: 0.19
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description (last modified by danielk)

When exiting live tv by hitting the esc key mythfrontend seg faults about 50 % of the time. It does this even when compiled with the default settings. The backtrace was generated with the latest svn version this morning.

[please use "Attach File" for backtraces. -- dtk]

Attachments (5)

1159-bt.txt (7.9 KB) - added by danielk 14 years ago.
gdb.txt (7.9 KB) - added by harley@… 14 years ago.
mythbackend.log (14.5 KB) - added by harley@… 14 years ago.
mythfrontend.log (123.7 KB) - added by harley@… 14 years ago.
1159.patch (1.3 KB) - added by danielk 14 years ago.
possible fix

Download all attachments as: .zip

Change History (13)

Changed 14 years ago by danielk

Attachment: 1159-bt.txt added

comment:1 Changed 14 years ago by danielk

Description: modified (diff)

comment:2 Changed 14 years ago by danielk

Can you provide a backtrace with the latest SVN, plus the logs from 'mythbackend -v record,channel' and 'mythfrontend -v playback'.

And please use 'Attach File'.

comment:3 Changed 14 years ago by harley@…

I attached the new backtrace and log files as requested. The backtrace was done against svn version 8817.

Changed 14 years ago by harley@…

Attachment: gdb.txt added

Changed 14 years ago by harley@…

Attachment: mythbackend.log added

Changed 14 years ago by harley@…

Attachment: mythfrontend.log added

comment:4 Changed 14 years ago by harley@…

New log and backtrace files with network logging attached.

Changed 14 years ago by danielk

Attachment: 1159.patch added

possible fix

comment:5 Changed 14 years ago by danielk

Harley, please try the attached.

I believe the problem is that a LIVETV_CHAIN message is still being processed after the NVP is deleted. In the patch I used the osdlock to avoid this happening. This lock is always locked while the NVP is deleted because the OSD gets deleted when the NVP is, if this is the problem here as well this should fix it (at least if you don't have a PiP NVP on screen; we don't use its OSD, so I don't know if the locking applies there).

comment:6 Changed 14 years ago by danielk

Owner: changed from Isaac Richards to danielk

comment:7 Changed 14 years ago by harley@…

The patch seems to have fixed it. I have been watching live tv for an hour now entering and exiting many times and it has not crashed once yet. Should probably test it for a little longer to make sure but it looks good. Thanks for the help Daniel.

comment:8 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [8848]) Fixes #1159.

Another segfault bites the dust. :)

This has Couple additional fixes to the patch I added to the ticket earlier, the pipnvp is now also protected by the osdlock.

What was happening was that an event using the nvp was being processed while the nvp was being deleted...

Note: See TracTickets for help on using tickets.