Opened 13 years ago

Closed 13 years ago

#1163 closed defect (worksforme)

LiveTV -> DVB (HD) playback stutters

Reported by: Mark de Jong <dejongm@…> Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

DVB stutters while watching live tv. Pressing pause/play pretty much clears it up. When using XvMC, playback is much better after pause/play but still some prebuffering pauses. As fas as I can tell this is only affecting 720p playback. Watching recorded programs works fine.

This ticket used to be #774, but since this is now out of the scope of 774, I've decided to create a new ticket. I have attached frontend logs for both XvMC and Standard playback. filenames with extention "vat" are video as timing. But I don't think video as timing makes that much of a difference. Each log starts off on the problem channel, then I pause and unpause and you can clearly see that the issue resolves itself (with the exception being XvMC which still has some prebuffering pauses).

Attachments (5)

mythfrontend-Standard-vat.log (128.4 KB) - added by Mark de Jong <dejongm@…> 13 years ago.
mythfrontend-Standard.log (167.6 KB) - added by Mark de Jong <dejongm@…> 13 years ago.
mythfrontend-xvmc-vat.txt (178.9 KB) - added by Mark de Jong <dejongm@…> 13 years ago.
mythfrontend-xvmc.log (225.4 KB) - added by Mark de Jong <dejongm@…> 13 years ago.
frontendlogs.tar.gz (42.0 KB) - added by Mark de Jong <dejongm@…> 13 years ago.

Download all attachments as: .zip

Change History (25)

Changed 13 years ago by Mark de Jong <dejongm@…>

Changed 13 years ago by Mark de Jong <dejongm@…>

Attachment: mythfrontend-Standard.log added

Changed 13 years ago by Mark de Jong <dejongm@…>

Attachment: mythfrontend-xvmc-vat.txt added

Changed 13 years ago by Mark de Jong <dejongm@…>

Attachment: mythfrontend-xvmc.log added

comment:1 Changed 13 years ago by Mark de Jong <dejongm@…>

Oh, and this is affecting SVN Revision 8791

comment:2 Changed 13 years ago by tralph11@…

Mark, your log for XvMC playback looks very similar to my problem in ticket #1158 I opened. Only difference is in my case the playback is smooth until I pause/play. After you pause/play could you try skipping back (5 sec skip) and see if the playback smooths out? Are you using the Chromakey OSD? Just wondering if this is a dupe.

comment:3 Changed 13 years ago by danielk

Version: head
  • What does "hdparm /dev/driver_used_by_recordings" say?
  • What kind of CPU do you have?
  • Does the patch in ticket #900 help?

comment:4 Changed 13 years ago by Mark de Jong <dejongm@…>

Daniel,

This is a 2.8 GHz P4. I'll apply the patch in #900 tomorrow. hdparm reports dma as 'on.'

tralph, skiping forward / back has no effect.

comment:5 Changed 13 years ago by tralph11@…

Daniel, I'm assuming the estbitrate of 12000 in the #900 ticket patch is for 12000kbps streams or higher. If Mark is dealing with a 720p stream that is lower than 12000kbps should he set the estbitrate threshold to something smaller in the #900 ticket patch? I changed mine to 8000 to make sure all my HD channels got the larger ringbuffer size. The change did seem to help my 720p stations.

Mark, make sure you also update to current svn since changeset [8797] seems to have helped my problem in ticket #1158.

comment:6 Changed 13 years ago by danielk

Milestone: 0.19
Owner: changed from Isaac Richards to danielk

comment:7 Changed 13 years ago by Mark de Jong <dejongm@…>

Milestone: 0.19

Man, I was writing some nice comments regarding things being fixed and then all of a sudden I started getting the same stuttering symptoms as before.

With SVN 8801 and #900 patch applied, XvMC is improved but still exhibits the stuttering problem. I've tried with and without Chromakey OSD and with and without "Video as Timebase". I have not tried for an extended amout of time (> 5 minutes).

Standard and libmpeg2 however, still has the same video stuttering issue. No improvement over unpatched/older SVN revision. The issue can still be fixed with a pause/unpause.

I wil try experimenting with different numbers in the #900 patch as ralph suggested and try without #900 altogether. I'll report my findings.

In the mean time, is there anything I can provide?

comment:8 Changed 13 years ago by tralph11@…

Mark, just check your output logs using -v playback and check the following line when your playback starts: RingBuf:CalcReadAheadThresh(45384 KB) -> threshhold(750 KB) readblocksize(500 KB)

The readblocksize should read 500KB. If it is set to 125KB then set the threshold lower than the estbitrate which is the first value printed in the message. You could also just hardcode the readblocksize to 512000 for testing purposes. It seems the patch as is works for all my HD channels. I must of been confused earlier.

BTW, I think you accidentally deleted the Milestone that Daniel set to 0.19.

comment:9 Changed 13 years ago by Mark de Jong <dejongm@…>

Milestone: 0.19

comment:10 Changed 13 years ago by tralph11@…

Mark, one thing you might want to double check is that your Nvidia drivers have AGP Enabled:

cat /proc/driver/nvidia/agp/status

comment:11 Changed 13 years ago by tralph11@…

Mark, you can also try increasing the "HD Ringbuffer size" found under Utilities/Setup?->Setup->TV Settings->General on the third page at the bottom. I adjusted mine from the default 9400 to 18800. I just now tried 9400 again and got stuttering during a 720p live-tv channel. So increasing this is definitely needed for my system. Hope this helps.

comment:12 Changed 13 years ago by tralph11@…

Oops, I'm an idiot. The reason I got stuttering was one of my ivtv tuners kicked in and was recording the same time I was watching 720p live-tv. Daniel has already diagnosed my problem as being related to #906. So I'm done with playing around with this until he fixes that ticket.

Daniel, sorry about some of the misinformation. Just trying to help. I'm going back into hiding for a while.

comment:13 Changed 13 years ago by danielk

Milestone: 0.19unknown

Mark de Jong, your CPU should be sufficient for playback. My suspicion is your disk is underperforming for some reason. Try increasing the "HD Ringbuffer size"; restart the backend after you change the value.

Is your disk formatted with XFS or JFS? Have you tried moving your DB to another disk?

Please e-mail me the responses. It's more efficient for a back and forth.

comment:14 Changed 13 years ago by Mark de Jong <dejongm@…>

Milestone: unknown0.19

Dan, Sorry but I don't have your email address. As of now it looks like #900 makes it worse. I've reverted back to your code. Suprisingly (right now) XvMC is working quite well even though the frontend is showing a lot of prebuffering pauses. I'm not noticing it visually.

Standard and libmpeg still have the same stuttering issue until I pause/unpause. Then everything works fine.

I already had my HD ringbuffer set to 32000K. I've both increased and decreased this setting and it has no effect.

My HD's are setup using lvm and striping over two 7200rpm drives. I'm using Reiserfs.

comment:15 Changed 13 years ago by Mark de Jong <dejongm@…>

I think I need to emphasis that there are a LOT of prebuffering pauses. Also, they do not appear when watching 1080i for either XvMC/Standard/libmpeg.

comment:16 Changed 13 years ago by danielk

Milestone: 0.190.20
Summary: LiveTV: DVB stutters, fixed by pause/playReiserFS + LiveTV -> playback stutters

ReiserFS is known to cause problems; especially for HDTV. You need subscribe to the developer mailing list, my e-mail is no secret there :) danielk AT cuymedia dt net.

comment:17 Changed 13 years ago by Markjan deJong <dejongm@…>

Summary: ReiserFS + LiveTV -> playback stuttersLiveTV -> DVB (HD) playback stutters

I moved from ReiserFS4 to JFS. Myth unfortunately still exhibits the same problem.

comment:18 Changed 13 years ago by Mark de Jong <dejongm@…>

On Feb 18, I was asked to see if this was fixed in latest SVN (after the audio patch). I tried 9079 and 9248 and still saw the same issue.

I have since updated to the latest 0-19-fixes release and with this release, XvMC still has some prebuffering pauses but is not visibly noticable and pause/unpause doesn't really seem to make a difference (as per the logs).

Standard still has the same symptoms (Video is X frames ahead of audio). Puase/Unpause? fixes this issue. New logs attached.

Will test more tonight with true HD content. The above tests were done on Standard Def content on an affected HD channel.

Changed 13 years ago by Mark de Jong <dejongm@…>

Attachment: frontendlogs.tar.gz added

comment:19 Changed 13 years ago by Mark de Jong <dejongm@…>

Update: After using for a few days, XvMC doesn't have to noticable visual affects but audio does stutter just a bit. This is also fixed with a pause/unpause. True HD content has the same symtoms as SD content on an HD channel.

comment:20 Changed 13 years ago by danielk

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.