Opened 6 years ago

Closed 6 years ago

#11643 closed Bug Report - General (Fixed)

Language changes in mythweb are not observed

Reported by: mythtv@… Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: 0.26-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Running mythweb 0.26.0-3.fc19 in Fedora 19, I am seeing problems with changing the language. Everything stays in English, which is my default locale. This might be a problem for someone whose native tongue isn't English.

At first, all of the time formats in Settings :: TV :: My Session were blank. Changing the language to English-CA populated the time format values. Changing to any other language failed to alter those values, or the language for the rest of the interface.

Change History (6)

comment:1 Changed 6 years ago by Nicolas Riendeau

Owner: set to Rob Smith
Status: newassigned

Hi Rob!

This is translation related but looks more like a PHP issue, could you please take a look at this?

Thank you!

Nicolas

comment:2 Changed 6 years ago by Nicolas Riendeau

Component: MythTV - GeneralPlugin - MythWeb

The issue is related to ticket #11603 and to the following thread on the mailing list: http://www.gossamer-threads.com/lists/mythtv/users/546819 (though it's not entirely fixed as the thread suggests).

comment:3 Changed 6 years ago by mythtv@…

This is fixed in http://code.mythtv.org/trac/ticket/11513 I just tested it and it works fine. I think this can be closed.

comment:4 Changed 6 years ago by Nicolas Riendeau

Status: assignedinfoneeded

Hi!

I applied the fix mentionned, could you please confirm if the problem is at least partially fixed by it?

(The language selection should work but the date formats do not should not I believe...)

Thank you!

Nicolas

comment:5 Changed 6 years ago by mythtv@…

For my setup, this change does in fact fix both the language selection and the date/time formats. I have seen this work in both Debian Wheezy with PHP 5.5 and with Fedora 19 (also with PHP 5.5).

comment:6 Changed 6 years ago by Nicolas Riendeau

Resolution: Fixed
Status: infoneededclosed
Note: See TracTickets for help on using tickets.