Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1166 closed defect (fixed)

PiP mode crashes, when switching windows

Reported by: mythtv.cvs@… Owned by: danielk
Priority: blocker Milestone: 0.19
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hardware: two ivtv tuners (350 and 250), using 'xv'.

Start mythfrontend, and then watch livetv. Use the livetv menu, and Enable picture-in-picture. Use livetv menu, and swap channels. Mythfrontend crashes (just before the crash, you can tell the swap was partially successful, as a few frames and sound make it from the now-primary swapped channel).

Using mythfrontend -v all, I get the following output (attached)...

By the way, a crash exists using pvr mpg350 out as well, but this debug output is from xv output)

Attachments (2)

pip.segfault.txt (67.0 KB) - added by anonymous 14 years ago.
gdb.txt (21.2 KB) - added by anonymous 14 years ago.

Download all attachments as: .zip

Change History (9)

Changed 14 years ago by anonymous

Attachment: pip.segfault.txt added

comment:1 Changed 14 years ago by danielk

Owner: changed from Isaac Richards to danielk
Version: head

comment:2 Changed 14 years ago by danielk

Resolution: invalid
Status: newclosed

I can't reproduce this.

Please attach a backtrace as specified in the backtrace link in TicketHowTo.

comment:3 Changed 14 years ago by mythtv.cvs@…

Ok, going through the steps now...

Changed 14 years ago by anonymous

Attachment: gdb.txt added

comment:4 Changed 14 years ago by mythtv.cvs@…

Resolution: invalid
Status: closedreopened

gdb.txt attached, as per request...

comment:5 Changed 14 years ago by danielk

Priority: minorblocker

I must have been a little too tired when I read this originally. I missed the significance of using the OSD menu to do everything.

It appears it is the OSD menu that is causing the problem, probably because we delete the OSD as part of tearing down the players, but the OSD is still in use by the OSD menu handlers...

comment:6 Changed 14 years ago by danielk

Resolution: fixed
Status: reopenedclosed

(In [8816]) Fixes #1166.

Tearing down the OSD in an OSD callback causes problems.. This sets a 'needToSwapPIP' variable that is processed outside the callback instead.

comment:7 Changed 14 years ago by mythtv.cvs@…

Works great!

Note: See TracTickets for help on using tickets.