Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#11705 closed Bug Report - General (fixed)

Jumping between chapters in DVD playback can crash

Reported by: jyavenard Owned by: jyavenard
Priority: critical Milestone: 0.27
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: peper03 Ticket locked: no

Description

During DVD playback; if you skip between chapters using either Page Up or Page Down.

It will often crash.

The cause is a racing condition between the player and the decoder thread. The player reset the avcodec context, while the decoder is currently using it.

Attachments (0)

Change History (2)

comment:1 Changed 9 months ago by Jean-Yves Avenard <jyavenard@…>

  • Resolution set to fixed
  • Status changed from new to closed

In 7e7a78c1693eff51313f63a582fdff04d787c3fb/mythtv:

Lock the various stream context to prevent racing conditions.

SeekReset? was called in player thread, which would reset the av streams, while sometimes in the middle of usage in the decoder thread.

Fixes #11705

comment:2 Changed 9 months ago by paulh

  • Milestone changed from unknown to 0.27
  • Version changed from Unspecified to Master Head

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.