Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#11706 closed Bug Report - General (fixed)

mythweb Program Detail page not reflecting settings for default template

Reported by: jharbestonus@… Owned by: Rob Smith
Priority: minor Milestone: 0.28
Component: Plugin - MythWeb Version: Master Head
Severity: medium Keywords: mythweb
Cc: Ticket locked: no

Description

As indicated by the subject, the program detail page does not reflect settings for the default template.

To reproduce, I made changes in the 'This channel' item within Mythfrontend, setting it to 'ON' in the default template.

I then started mythweb and selected a show from the Listings page, opened advanced options, and verified that the 'this channel' item was not changed to the 'ON' state.

Attachments (2)

mythverfile.txt (945 bytes) - added by jharbestonus@… 6 years ago.
mythtv version info
mythweb_default_filters_fix.patch (1.5 KB) - added by Karl Newman <SiliconFiend@…> 6 years ago.
Desist using "newruledefault" values from the recordfilter table, which will cause a new rule to use the filters from the Default recording template.

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by jharbestonus@…

Attachment: mythverfile.txt added

mythtv version info

comment:1 Changed 6 years ago by sphery

Component: MythTV - GeneralPlugin - MythWeb
Owner: set to Rob Smith

comment:2 Changed 6 years ago by sphery

MythWeb has only partial support for Recording Rule Templates (see #11512). This isn't a bug--it's a not-yet-implemented feature.

Changed 6 years ago by Karl Newman <SiliconFiend@…>

Desist using "newruledefault" values from the recordfilter table, which will cause a new rule to use the filters from the Default recording template.

comment:3 Changed 6 years ago by Karl Newman <SiliconFiend@…>

It actually is a bug because it is not using the filter values from the Default template (but it is using the other values). The above patch should fix it, but I don't know if there are other uses of the "newruledefault" column. From what I can grep there is no other usage of that (or the functions which contain it) anywhere else in mythweb.

comment:4 Changed 6 years ago by Karl Dietz <dekarl@…>

Resolution: fixed
Status: newclosed

In fc8db228e47ff6c205e1c7bceb7b984652086ba8/mythweb:

use the filter values from the Default template

Patch by Karl Newman
Fixes #11706

comment:5 Changed 5 years ago by paulh

Milestone: unknown0.28
Note: See TracTickets for help on using tickets.