Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#11707 closed Bug Report - General (fixed)

MythTV front end Media Library > Image Gallery menu not available

Reported by: jtl_@… Owned by: paulh
Priority: minor Milestone: 0.28
Component: Plugin - MythGallery Version: 0.25-fixes
Severity: medium Keywords: Image Menu
Cc: Ticket locked: no

Description

Pressing M for the menu has no effect until at least one picture exists in the default folder for pictures. This prevents importing and picture . . .

Change History (4)

comment:1 Changed 6 years ago by Raymond Wagner

Priority: majorminor
Severity: highmedium

Resetting defaults.

comment:2 Changed 6 years ago by Raymond Wagner

Owner: set to paulh
Status: newassigned

Paul, I'm assigning this to you since your name is on the blame list. The issue is that in iconview.cpp, line 442, you require the itemList to be populated before the MENU action can be handled. Is there any harm to moving that outside the itemList check? Would this need a separate main menu popup, or perhaps some code in IconView::HandleMainMenu? to filter out certain options if there are no images available?

comment:3 Changed 5 years ago by Paul Harrison <pharrison@…>

Resolution: fixed
Status: assignedclosed

In 88bc3a9c6113e417a1020dd5dbe913c5908a903d/mythtv:

MythGallery: fix showing the menu for folders that contain no images

Fixes #11707.

comment:4 Changed 5 years ago by paulh

Milestone: unknown0.28
Note: See TracTickets for help on using tickets.