Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11760 closed Bug Report - General (Duplicate)

Inappropriate ioctl for device

Reported by: todd bailey <toddb@…> Owned by: stuartm
Priority: minor Milestone: 0.27
Component: MythTV - Mythtv-setup Version: Master Head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Adding HD-PVR returns this error when trying to access device, additionally front end seg faults.

back end log 2013-08-17 12:36:31.689343 I MainServer::ANN Playback 2013-08-17 12:36:31.689350 I adding: mythtv as a client (events: 0) 2013-08-17 12:36:31.700703 I TVRec(3): Changing from None to WatchingLiveTV 2013-08-17 12:36:31.704159 I TVRec(3): HW Tuner: 3->3 2013-08-17 12:36:31.740004 I V4LChannel(/dev/video1): SetInputAndFormat?(3, NTSC) (v4l v2) input_switch: 0 mode_switch: 0 2013-08-17 12:36:31.740032 E Channel(/dev/video1)::Tune(): Error -1 while setting frequency (v2): Inappropriate ioctl for device 2013-08-17 12:36:31.740041 E TVRec(3): Failed to set channel to 5. Reverting to kState_None 2013-08-17 12:36:31.740058 I TVRec(3): Changing from WatchingLiveTV to None

Front end log

2013-08-17 12:35:28.669071 I TV: Changing from None to WatchingLiveTV 2013-08-17 12:35:28.669080 I TV: State is LiveTV & mctx == ctx 2013-08-17 12:35:28.670192 I TV: UpdateOSDInput done 2013-08-17 12:35:28.670203 I TV: UpdateLCD done 2013-08-17 12:35:28.670422 I TV: ITVRestart done 2013-08-17 12:35:28.671588 I TV: Main UI disabled. 2013-08-17 12:35:28.799266 I TV: Entering main playback loop. 2013-08-17 12:35:28.840914 I ScreenSaverX11Private: DPMS Deactivated 1 2013-08-17 12:35:29.099294 I VDPAU: Added 2 output surfaces (total 4, max 4) 2013-08-17 12:35:29.205349 I Using protocol version 75 2013-08-17 12:35:29.206580 I Using protocol version 75 2013-08-17 12:35:31.126147 W MythPainter?: 3 images not yet de-allocated. 2013-08-17 12:35:31.126168 I VDPAU Painter: Clearing VDPAU painter cache. 2013-08-17 12:35:31.160397 I Clearing OpenGL painter cache. 2013-08-17 12:35:31.224436 I VDPAU: Created 2 output surfaces. 2013-08-17 12:35:31.224459 I VDPAU: Created VDPAU render device 1600x1200 2013-08-17 12:35:31.235004 N Player(0): Forcing decode extra audio option on (Video method requires it). 2013-08-17 12:35:31.235236 I AFD: Opened codec 0x1967bc0, id(MPEG2VIDEO) type(Video) 2013-08-17 12:35:31.235245 I AFD: codec AC3 has 2 channels 2013-08-17 12:35:31.235659 I AFD: Opened codec 0x1910340, id(AC3) type(Audio) 2013-08-17 12:35:32.212526 I AO: Opening audio device 'default' ch 2(2) sr 48000 sf signed 16 bit reenc 0 2013-08-17 12:35:32.273862 N AFD: Resetting byte context eof (livetv 1 was eof 0) 2013-08-17 12:35:33.025135 I VDPAU: Added 2 output surfaces (total 4, max 4) 2013-08-17 12:35:33.279599 N Player(0): Waited 103ms for video buffers AAAAAAAAADDdLf 2013-08-17 12:35:33.382672 N Player(0): Waited 206ms for video buffers AAAAAAAAADDdLf 2013-08-17 12:35:33.487012 N Player(0): Waited 310ms for video buffers AAAAAAAAADDdLf 2013-08-17 12:35:33.590375 N Player(0): Waited 414ms for video buffers AAAAAAAAADDdLf 2013-08-17 12:35:38.371478 N Player(0): Waited 103ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:38.472238 N Player(0): Waited 204ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:38.573729 N Player(0): Waited 305ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:38.697819 N Player(0): Waited 429ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:38.799148 N Player(0): Waited 531ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:38.901699 N Player(0): Waited 633ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.004057 N Player(0): Waited 736ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.106424 N Player(0): Waited 838ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.209469 N Player(0): Waited 941ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.311916 N Player(0): Waited 1043ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.413350 N Player(0): Waited 1145ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.516255 N Player(0): Waited 1248ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.619235 N Player(0): Waited 1351ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.723474 N Player(0): Waited 1455ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.826489 N Player(0): Waited 1558ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.929738 N Player(0): Waited 1661ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.952872 W RingBuf?(myth://192.168.1.10:6543/3042_20130817193529.mpg): Taking too long to be allowed to read.. 2013-08-17 12:35:40.032763 N Player(0): Waited 1764ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:40.135795 N Player(0): Waited 1867ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:36:31.096107 I Clearing OpenGL painter cache. 2013-08-17 12:36:31.390335 I VDPAU Painter: Clearing VDPAU painter cache. 2013-08-17 12:36:31.686946 I MythCoreContext?: Connecting to backend server: 192.168.1.10:6543 (try 1 of 10) 2013-08-17 12:36:31.689159 I Using protocol version 75 2013-08-17 12:36:31.744473 I Using protocol version 75 2013-08-17 12:36:31.745023 I Using protocol version 75 2013-08-17 12:37:11.764017 E TV: StartRecorder?() -- timed out waiting for recorder to start 2013-08-17 12:37:11.764029 E TV: LiveTV not successfully started Handling Segmentation fault Segmentation fault

Change History (6)

comment:1 in reply to:  description ; Changed 6 years ago by todd bailey <toddb@…>

Replying to todd bailey <toddb@…>:

Adding HD-PVR returns this error when trying to access device, additionally front end seg faults.

back end log 2013-08-17 12:36:31.689343 I MainServer::ANN Playback 2013-08-17 12:36:31.689350 I adding: mythtv as a client (events: 0) 2013-08-17 12:36:31.700703 I TVRec(3): Changing from None to WatchingLiveTV 2013-08-17 12:36:31.704159 I TVRec(3): HW Tuner: 3->3 2013-08-17 12:36:31.740004 I V4LChannel(/dev/video1): SetInputAndFormat?(3, NTSC) (v4l v2) input_switch: 0 mode_switch: 0 2013-08-17 12:36:31.740032 E Channel(/dev/video1)::Tune(): Error -1 while setting frequency (v2): Inappropriate ioctl for device 2013-08-17 12:36:31.740041 E TVRec(3): Failed to set channel to 5. Reverting to kState_None 2013-08-17 12:36:31.740058 I TVRec(3): Changing from WatchingLiveTV to None

Front end log

2013-08-17 12:35:28.669071 I TV: Changing from None to WatchingLiveTV 2013-08-17 12:35:28.669080 I TV: State is LiveTV & mctx == ctx 2013-08-17 12:35:28.670192 I TV: UpdateOSDInput done 2013-08-17 12:35:28.670203 I TV: UpdateLCD done 2013-08-17 12:35:28.670422 I TV: ITVRestart done 2013-08-17 12:35:28.671588 I TV: Main UI disabled. 2013-08-17 12:35:28.799266 I TV: Entering main playback loop. 2013-08-17 12:35:28.840914 I ScreenSaverX11Private: DPMS Deactivated 1 2013-08-17 12:35:29.099294 I VDPAU: Added 2 output surfaces (total 4, max 4) 2013-08-17 12:35:29.205349 I Using protocol version 75 2013-08-17 12:35:29.206580 I Using protocol version 75 2013-08-17 12:35:31.126147 W MythPainter?: 3 images not yet de-allocated. 2013-08-17 12:35:31.126168 I VDPAU Painter: Clearing VDPAU painter cache. 2013-08-17 12:35:31.160397 I Clearing OpenGL painter cache. 2013-08-17 12:35:31.224436 I VDPAU: Created 2 output surfaces. 2013-08-17 12:35:31.224459 I VDPAU: Created VDPAU render device 1600x1200 2013-08-17 12:35:31.235004 N Player(0): Forcing decode extra audio option on (Video method requires it). 2013-08-17 12:35:31.235236 I AFD: Opened codec 0x1967bc0, id(MPEG2VIDEO) type(Video) 2013-08-17 12:35:31.235245 I AFD: codec AC3 has 2 channels 2013-08-17 12:35:31.235659 I AFD: Opened codec 0x1910340, id(AC3) type(Audio) 2013-08-17 12:35:32.212526 I AO: Opening audio device 'default' ch 2(2) sr 48000 sf signed 16 bit reenc 0 2013-08-17 12:35:32.273862 N AFD: Resetting byte context eof (livetv 1 was eof 0) 2013-08-17 12:35:33.025135 I VDPAU: Added 2 output surfaces (total 4, max 4) 2013-08-17 12:35:33.279599 N Player(0): Waited 103ms for video buffers AAAAAAAAADDdLf 2013-08-17 12:35:33.382672 N Player(0): Waited 206ms for video buffers AAAAAAAAADDdLf 2013-08-17 12:35:33.487012 N Player(0): Waited 310ms for video buffers AAAAAAAAADDdLf 2013-08-17 12:35:33.590375 N Player(0): Waited 414ms for video buffers AAAAAAAAADDdLf 2013-08-17 12:35:38.371478 N Player(0): Waited 103ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:38.472238 N Player(0): Waited 204ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:38.573729 N Player(0): Waited 305ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:38.697819 N Player(0): Waited 429ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:38.799148 N Player(0): Waited 531ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:38.901699 N Player(0): Waited 633ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.004057 N Player(0): Waited 736ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.106424 N Player(0): Waited 838ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.209469 N Player(0): Waited 941ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.311916 N Player(0): Waited 1043ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.413350 N Player(0): Waited 1145ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.516255 N Player(0): Waited 1248ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.619235 N Player(0): Waited 1351ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.723474 N Player(0): Waited 1455ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.826489 N Player(0): Waited 1558ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.929738 N Player(0): Waited 1661ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:39.952872 W RingBuf?(myth://192.168.1.10:6543/3042_20130817193529.mpg): Taking too long to be allowed to read.. 2013-08-17 12:35:40.032763 N Player(0): Waited 1764ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:35:40.135795 N Player(0): Waited 1867ms for video buffers ADdAAAAAAAAALd 2013-08-17 12:36:31.096107 I Clearing OpenGL painter cache. 2013-08-17 12:36:31.390335 I VDPAU Painter: Clearing VDPAU painter cache. 2013-08-17 12:36:31.686946 I MythCoreContext?: Connecting to backend server: 192.168.1.10:6543 (try 1 of 10) 2013-08-17 12:36:31.689159 I Using protocol version 75 2013-08-17 12:36:31.744473 I Using protocol version 75 2013-08-17 12:36:31.745023 I Using protocol version 75 2013-08-17 12:37:11.764017 E TV: StartRecorder?() -- timed out waiting for recorder to start 2013-08-17 12:37:11.764029 E TV: LiveTV not successfully started Handling Segmentation fault Segmentation fault

steps to repro:

stop frontend and backend open myth-setup in capture cards menu, add hdvpr as h.264 encoder, click finish In video sources create a video source, schedules direct in my case enter required user acct info, passwd , video source name etc. click retrieve lineups, this sometimes will time out so click again until lineuop fetch is successful verify line up name is correct for capture device/set top box click finish and escape to main menu in input connections, provide a name for the display, supply video source name (created in video source menu) enter path of external channel change command, (test in a command window to insure no error are produced, set mode to 777) enter a channel to preset to. fetch channels from listings set a starting channel and click next and finish, escape to main menu and escape to exit now start backend and front end in front end select view live tv and select a channel connected to hd-pvr and wait until front end segfaults

comment:2 in reply to:  1 Changed 6 years ago by Raymond Wagner

Resolution: Invalid
Status: newclosed

Replying to todd bailey <toddb@…>:

enter a channel to preset to.

Don't do this. HDPVRs are not tuners.

comment:3 Changed 6 years ago by stuartm

Component: MythTV - GeneralMythTV - Mythtv-setup
Milestone: unknown0.27
Owner: set to stuartm
Severity: mediumlow
Version: UnspecifiedMaster Head

I'll change it so that for 0.27 we don't show this setting for the HDPVR or any other cards where it's not appropriate. It's currently only excluded for Digital Tuners.

comment:4 Changed 6 years ago by stuartm

Resolution: Invalid
Status: closednew

comment:5 Changed 6 years ago by stuartm

Resolution: Duplicate
Status: newclosed

Duplicate of #11761

comment:6 Changed 6 years ago by todd bailey <toddb@…>

Thanks so much for having such an easy fix. I've been fighting this problem ever since I upgraded from .24

glad to have semi HD working again

Note: See TracTickets for help on using tickets.