Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11775 closed Bug Report - General (fixed)

editing a recording schedule unconditionally enables autoexpiry

Reported by: Karl Egly Owned by: Rob Smith
Priority: minor Milestone: 0.26.2
Component: Plugin - MythWeb Version: Master Head
Severity: medium Keywords:
Cc: sascha@… Ticket locked: no

Description

The scheduler editor in mythweb always populates the form with autoexpiry enabled regardless of the actual value in the database. Saving the modified schedule then enables auto expiry even if it is not what the user intended. Seen on fixes/0.26 and can be reproduced on master

Change History (3)

comment:1 Changed 7 years ago by Karl Dietz <dekarl@…>

Resolution: fixed
Status: newclosed

In 08b94cea6346ebeb94edf98ecb5d7b7dd8555560/mythweb:

fix merge in schedule templates added in f97529656

if (!$this->$name) ends up as if(!0)...

Fixes #11775

comment:2 Changed 7 years ago by Karl Dietz <dekarl@…>

In 5d8ffe109286269ada87390a2b74e142ec36e364/mythweb:

fix merge in schedule templates added in f97529656

if (!$this->$name) ends up as if(!0)...

Fixes #11775

(cherry picked from commit 08b94cea6346ebeb94edf98ecb5d7b7dd8555560)

comment:3 Changed 7 years ago by Karl Egly

Milestone: unknown0.26.2
Note: See TracTickets for help on using tickets.