Opened 6 years ago

Closed 6 years ago

#11784 closed Bug Report - General (Duplicate)

MythLogServer multiple instances, each hanging with high CPU load until killed

Reported by: barth@… Owned by: beirdo
Priority: major Milestone: unknown
Component: MythTV - Mythlogserver Version: Unspecified
Severity: medium Keywords: hang
Cc: Ticket locked: no

Description

On my system (fresh installed Ubuntu 13.04), since the introduction of MythLogServer?, there are always multiple instances of MythLogServer? coming up in a very short time. Each of them eats up as much CPU as it can get. I had to add a cron job that kills all instances of MythLogServer? each minute, so there are only 1-3 running at a time, nevertheless, the CPU load is always at 100% and my living room is always pretty warm.

If you google for it, you see that there are/were other people who seem to have the same issue. One of them was talking about NVIDIA driver version... I did not try changing the native NVIDIA drivers yet, because I don´t have any other issues with it, and I can´t really believe the graphics driver is related to logging.

This is my process list, filtered, about 8 minutes after the last kill (I changed the upstart script parameter of MythBackend? to --nodblog, because I thought that would perhaps help, but it didn´t)

1722 ? Rsl 1:40 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog 1754 ? Rsl 1:33 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog 1776 ? Rsl 0:55 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog 1814 ? Rsl 1:25 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog 1914 ? SNsl 1:02 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog 1925 ? Rsl 1:18 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --syslog local7 1947 ? RNsl 0:38 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog 1962 ? Rsl 1:07 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --syslog local7 1973 ? Rsl 1:04 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog 2062 ? Rsl 1:01 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --syslog local7 2072 ? Rsl 0:42 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog 2085 ? RNsl 0:44 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog 2103 ? Rsl 0:44 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog 2114 ? RNsl 0:29 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog 2125 ? Ssl 0:20 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --syslog local7 2135 ? Ssl 0:08 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog 2174 ? Ssl 0:12 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog 2207 ? Rsl 0:09 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog 2220 ? Rsl 0:07 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --syslog local7 2231 ? Rsl 0:06 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog 2248 ? Rsl 0:02 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --syslog local7 2283 ? Rsl 0:00 /usr/bin/mythlogserver --daemon --verbose general --loglevel info --nodblog

Change History (1)

comment:1 Changed 6 years ago by JYA

Resolution: Duplicate
Status: newclosed

duplicate of #11230

Note: See TracTickets for help on using tickets.