Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#11791 closed Bug Report - General (fixed)

MythTV confused with multiple programs in PAT

Reported by: johan@… Owned by: jpoet
Priority: minor Milestone: 0.27.1
Component: MythTV - Recording Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Karl Egly)

New bug report because of http://code.mythtv.org/trac/ticket/11487#comment:7

When there are multiple programs found in an IPTV stream, MythTV gets confused and won't play/record the IPTV stream while mplayer and VLC have no problem with the stream.

(HandlePAT) DTVSM(): Program #1 not found in PAT!
Program Association Section
 PSIP tableID(0x0) length(17) extension(0x451)
      version(9) current(1) section(0) last_section(0)
      tsid(1105) programCount(2)
  program number     0 has PID 0x0010
  program number  4016 has PID 0x0844

(ProcessPAT) ProcessPAT: Program not found in PAT. Rescan your transports.

(CreatePATSingleProgram) Desired program #1 not found in PAT.
                         Cannot create single program PAT.

Attachments (1)

0002-extend-IPTV-hack-to-handle-PAT-with-two-entries-but-.patch (1.8 KB) - added by Karl Egly 6 years ago.
draft patch

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by jpoet

Owner: changed from danielk to jpoet
Status: newaccepted
Version: 0.26-fixesMaster Head

comment:2 Changed 6 years ago by Karl Egly

Description: modified (diff)

comment:3 Changed 6 years ago by Stuart Auchterlonie

Okay,

So the issue is exactly as the error says it is

Program #1 not found in PAT. What programs are in the PAT?

program number 0 has PID 0x0010 program number 4016 has PID 0x0844

nope, neither of those are program number 1.

So there is a mismatch between your channel configuration and what is being streamed via iptv

comment:4 Changed 6 years ago by johan@…

This is IPTV, not DVB.

Unfortunately for IPTV channels in MythTV, there is currently no way to tell what program number(s) to expect. The ticket referenced is a patch that makes is possible to specify the program number MythTV should use for the IPTV stream.

Unlike DVB, where this information is stored in the database, for IPTV this information is not yet available. MythTV expects only one program and uses that.

In this case there are 2 program IDs available in the stream, and MythTV is confused and doesn't play/record the stream.

Changed 6 years ago by Karl Egly

draft patch

comment:5 Changed 6 years ago by Karl Dietz <dekarl@…>

In 3bd3c71551a938eec2bb50feb48501136704392d/mythtv:

extend IPTV hack to handle PAT with two entries but only one program

Refs #11791

comment:6 Changed 6 years ago by splok@…

I'm not an expert regarding this subject, but program number "0" is a special one and should never be considered as a valid program. If program 0 is simply ignored in this case, MythTV will work as required for recording this stream.

According to Wikipedia: (http://en.wikipedia.org/wiki/MPEG_transport_stream) "The value 0x0000 of program_number is reserved to specify the PID where to look for Network Information Table (NIT). If such a program is not present in PAT the default PID value (0x0010) shall be used for NIT."

comment:7 Changed 5 years ago by Karl Dietz <dekarl@…>

Resolution: fixed
Status: acceptedclosed

In 9d4b5e2313ea0b1eb7718264782f529bd88c555d/mythtv:

extend IPTV hack to handle PAT with two entries but only one program

Fixes #11791

(cherry picked from commit 3bd3c71551a938eec2bb50feb48501136704392d)

comment:8 Changed 5 years ago by Karl Egly

Milestone: unknown0.27.1
Note: See TracTickets for help on using tickets.