Opened 8 years ago

Closed 4 weeks ago

#11850 closed Bug Report - General (Fixed)

Video metadata retrieval fails on movies that are number only

Reported by: wenenfweni@… Owned by: Raymond Wagner
Priority: minor Milestone: unknown
Component: Contributed Scripts & Apps Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If you have a movie with a title consisting only of a number (42.mkv for instance), metadata retrieval fails. Running 'tmdb3.py --movielist 42' returns a long list of titles so the issue is likely in the logic that tries to smartly parse the filename to a movie title.

On a related note, I had another movie title with numbers that properly retrieved the expected tmdb id, but got interpreted as having a season/episode number and then pulled metadata from thetvdb.com using the tmdb movie id. This may have been 'Movie 43.mkv'.

I am running the latest code from GIT as of an hour ago.

Change History (4)

comment:1 Changed 8 years ago by Raymond Wagner

Component: MythTV - GeneralContributed Scripts & Apps
Owner: set to Raymond Wagner
Status: newaccepted

comment:2 Changed 10 months ago by Stuart Auchterlonie

Milestone: unknownneeds_triage

comment:3 Changed 5 weeks ago by steveerl

The initial reported problem with the movie "42" was fixed by my solution to #13159 (Automatic lookup of metadata should prefer exact title match over partial title matches). Before that fix, if the metadata lookup returned multiple partial title matches, none of them would be picked. Since #13159 was merged in 3 years ago, as long as there is only one movie called "42", the artwork is properly retrieved and displayed. I recorded "42" a few weeks ago, and the artwork retrieval worked perfectly.

To test the related note issue, I set up a manual record rule using "Movie 43", and the metadata retrieval pulled up artwork showing Anna Faris, Halle Berry, Richard Gere, etc. That issue seems to be resolved.

I suggest this ticket be closed since the issues are fixed by the solution to other ticket(s).

comment:4 Changed 4 weeks ago by Stuart Auchterlonie

Milestone: needs_triageunknown
Resolution: Fixed
Status: acceptedclosed

Reported fixed. Closing

Note: See TracTickets for help on using tickets.