Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11891 closed Bug Report - General (fixed)

Guide EPG aligned to start of the program, regardless of the length of the program

Reported by: drewvs@… Owned by: gigem
Priority: minor Milestone: 0.27.1
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

As the title suggests, when watching live TV the guide does not properly align itself to the current time. For instance, if a 3 hour movie is playing, the guide will show the beginning of the program and not the expected current time-frame.

This did not happen in .26 or below. The database, frontend, and backend has been completely rebuilt before filing this bug.

I have wiped the program database table and ran mythfilldatabase with the grab option to wipe and pull all data (don't recall the parameter) as mentioned in IRC.

This happens on all themes available.

Screenshot and logs attached.

Attachments (2)

mythfrontend.20131005195437.15397.log (28.4 KB) - added by drewvs@… 6 years ago.
frontend_log
screenshot_frontend.png (576.1 KB) - added by drewvs@… 6 years ago.
frontend_shot

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by drewvs@…

frontend_log

Changed 6 years ago by drewvs@…

Attachment: screenshot_frontend.png added

frontend_shot

comment:1 Changed 6 years ago by drewvs@…

Version is .27 pull from a few days ago.

comment:2 Changed 6 years ago by Raymond Wagner

Version: Unspecified0.27-fixes

comment:3 Changed 6 years ago by stuartm

Milestone: unknown0.27.1
Owner: set to gigem
Status: newassigned
Version: 0.27-fixesMaster Head

Looks like this was caused by [7d6d0492], reassigning to David

comment:4 Changed 6 years ago by David Engel <dengel@…>

Resolution: fixed
Status: assignedclosed

In f154c07f7fc6106a59c37b185a8f34b6f9df7eef/mythtv:

Always use current time when entering EPG from live TV.

Fixes #11891

comment:5 Changed 6 years ago by David Engel <dengel@…>

In 756d95d85f9d2049b667edeb269668b502839418/mythtv:

Always use current time when entering EPG from live TV.

Backported from master.

Refs #11891

Note: See TracTickets for help on using tickets.