Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 6 months ago

Closed 3 weeks ago

Last modified 3 weeks ago

#11901 closed Bug Report - General (fixed)

AirPlay issues

Reported by: Craig Treleaven <ctreleaven@…> Owned by: jyavenard
Priority: minor Milestone: unknown
Component: MythTV - Airplay Version: 0.27-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

Issues with AirPlay? from iPhone 5/iOS 7.0.2 to Myth 0.27-fixes frontend. Using Video or YouTube? apps, audio usually plays but video is not always displayed. Using Photos app, pictures are never displayed and sometimes Myth is not listed as a possible AirPlay? target.

For more detail, see IRC logs and mythtv-users list discussions:
http://irc.mythtv.org/ircLog/channel/4/2013-10-08
http://www.gossamer-threads.com/lists/mythtv/users/554980

Attachments (6)

Version_info.txt (759 bytes) - added by Craig Treleaven <ctreleaven@…> 6 months ago.
--version output
mythfrontend.20131010130247.44272.log (623.9 KB) - added by Craig Treleaven <ctreleaven@…> 6 months ago.
-v playback --loglevel=debug
BB_AirPlay_20130ct10_1.png (88.4 KB) - added by Craig Treleaven <ctreleaven@…> 6 months ago.
Bonjour Browser: AirPlay? info
BB_AirTunes_20130ct10_1.png (92.4 KB) - added by Craig Treleaven <ctreleaven@…> 6 months ago.
Bonjour Browser: AirTunes? info
Terminal 1 2013Oct11.txt (3.7 KB) - added by Craig Treleaven <ctreleaven@…> 6 months ago.
Terminal 2 2013Oct11.txt (2.8 KB) - added by Craig Treleaven <ctreleaven@…> 6 months ago.

Download all attachments as: .zip

Change History (12)

Changed 6 months ago by Craig Treleaven <ctreleaven@…>

--version output

Changed 6 months ago by Craig Treleaven <ctreleaven@…>

-v playback --loglevel=debug

Changed 6 months ago by Craig Treleaven <ctreleaven@…>

Bonjour Browser: AirPlay? info

Changed 6 months ago by Craig Treleaven <ctreleaven@…>

Bonjour Browser: AirTunes? info

comment:1 Changed 6 months ago by Craig Treleaven <ctreleaven@…>

Attempted 3 AirPlay? activities in attached log:

1) Played video podcast from iTunes (11.1 on MBP running 10.6.8) to mythfrontend (.27-fixes as of 10/10). Played fine.

2) Videos app (iOS 7.0.2 on iPhone 5). Audio played on frontend but no video.

3) Photos app (same). Frontend not listed as an AirPlay? target.

comment:2 Changed 6 months ago by jyavenard

on your mac:
do the following:

close mythfrontend if there are any running.

Each command must be run in a separate terminal (they are blocking, and once you're done press Ctrl-C to interrupt).

# 1
Terminal 1:

dns-sd -R 5855CA123456@MythTV _raop._tcp local 49152 "txtvers=1" "ch=2" "cn=0,1" "et=0,3" "sv=false" "da=true" "sr=44100" "ss=16" "pw=false" "vn=65537" "tp=TCP,UDP" "md=0,1,2" "vs=104.29" "am=AppleTV2,1" "sf=0x4"

Terminal 2:

 dns-sd -R "MythTV" _airplay._tcp local 7000 "deviceid=58:55:CA:12:34:56" "features=0x7" "model=AppleTV2,1"

See if the device appear on iTunes on the mac, and on the iPhone in the control center; report

# 2
Terminal 1:

dns-sd -R 5855CA123456@MythTV _raop._tcp local 49152 "txtvers=1" "ch=2" "cn=0,1,2,3" "da=true" "et=0,3,5" "md=0,1,2" "pw=false" "sv=false" "sr=44100" "ss=16" "tp=UDP" "vn=65537" "vs=130.14" "am=AppleTV2,1" "sf=0x4"

Terminal 2:

dns-sd -R "MythTV" _airplay._tcp local 7000 "deviceid=58:55:CA:12:34:56" "features=0x39f7" "model=AppleTV2,1" "srcvers=130.14"}}}

See if the device appear on iTunes on the mac, and on the iPhone in the control center; report

# 3:
Terminal 1:

dns-sd -R 5855CA123456@MythTV _raop._tcp local 49152 "sf=0x4" "am=AppleTV2,1" "vs=130.14" "vn=65537" "tp=UDP" "ss=16" "sr=44100" "sv=false" "pw=false" "md=0,1,2" "et=0,3,5" "da=true" "cn=0,1,2,3" "ch=2" "txtvers=1"

Terminal 2:

 dns-sd -R "MythTV" _airplay._tcp local 7000 "srcvers=130.14" "model=AppleTV2,1" "features=0x39f7" "deviceid=58:55:CA:12:34:56"

See if the device appear on iTunes on the mac, and on the iPhone in the control center; report

# 4:
Terminal 1:

dns-sd -R 5855CA123456@MythTV _raop._tcp local 49152 "md=0,1,2" "txtvers=1" "vn=3" "pw=false" "sr=44100" "ss=16" "ch=2" "cn=0,1" "et=0,1" "ek=1" "sv=false" "sm=false" "tp=UDP"

Terminal 2:

dns-sd -R "MythTV" _airplay._tcp local 7000 "srcvers=101.28" "model=AppleTV2,1" "features=0x77" "deviceid=58:55:CA:12:34:56"

See if the device appear on iTunes on the mac, and on the iPhone in the control center; report

# 5:
Terminal 1:

dns-sd -R 5855CA123456@MythTV _raop._tcp local 49152 "tp=UDP" "sm=false" "sv=false" "ek=1" "et=0,1" "cn=0,1" "ch=2" "ss=16" "sr=44100" "pw=false" "vn=3" "txtvers=1" "md=0,1,2"

Terminal 2:

dns-sd -R "MythTV" _airplay._tcp local 7000 "deviceid=58:55:CA:12:34:56" "features=0x77" "model=AppleTV2,1" "srcvers=101.28"

# 6:
Terminal 1:

dns-sd -R 5855CA123456@MythTV _raop._tcp local 49152 "ss=16" "rhd=4.7.1" "sr=44100" "ch=2" "sv=false" "vs=150.33" "md=0,1,2" "vn=65537" "txtvers=1" "am=AppleTV3,2" "pw=false" "vv=1" "tp=UDP" "sf=0x4" "da=true" "cn=1,2,3" "et=0,3,5"

Terminal 2:

dns-sd -R "MythTV" _airplay._tcp local 7000 "srcvers=150.33" "vv=1" "model=AppleTV3,2" "deviceid=58:55:CA:12:34:56" "features=0x100029ff" "rhd=4.7.1"

See if the device appear on iTunes on the mac, and on the iPhone in the control center; report

# 7:
Terminal 1:

dns-sd -R 5855CA123456@MythTV _raop._tcp local 49152 "da=true" "vs=115.2" "md=0,1,2" "txtvers=1" "vn=3" "pw=false" "sr=44100" "ss=16" "ch=2" "cn=0,1" "et=0,1" "ek=1" "sv=false" "sm=false" "tp=UDP"

Terminal 2:

dns-sd -R "MythTV" _airplay._tcp local 7000 "srcvers=115.2" "model=AppleTV2,1" "features=0xE1B" "deviceid=58:55:CA:12:34:56" 

See if the device appear on iTunes on the mac, and on the iPhone in the control center; report

For the record:
# 1 is an Apple TV 2 running iOS 4
# 2 is an Apple TV 2 running iOS 6
# 3 is an Apple TV 2 running iOS 6 with the dns arguments reversed
# 4 is MythTV AirPlay? video back in late 2012
# 5 is MythTV with first version of RAOP in Jan 2012
# 6 is AirServer? (they have implemented FairPlay?.
# 7 is MythTV version 0.27 as of today


The more it goes, the more I think it's:
a) a bug in iOS 7 (my Apple TV currently shows up as audio only, no video or

b) they are now requiring a more recent version of their ATV iOS, which unfortunately require FairPlay? support, which we can't provide

# 7 gives me consistent results, and now that all my devices have been updated to that version, I get goot and reliable result

comment:3 Changed 6 months ago by Craig Treleaven <ctreleaven@…>

Not sure what you expected to see, but following are the results. I'll attach logs from the two Terminal sessions.

 # 1 is an Apple TV 2 running iOS 4
iTunes: Yes
iOS: No
 # 2 is an Apple TV 2 running iOS 6
iTunes: Yes
iOS: Yes
 # 3 is an Apple TV 2 running iOS 6 with the dns arguments reversed
iTunes: Yes
iOS: Yes
 # 4 is MythTV AirPlay video back in late 2012
iTunes: Yes
iOS: Yes
 # 5 is MythTV with first version of RAOP in Jan 2012
iTunes: Yes
iOS: Yes
 # 6 is AirServer (they have implemented FairPlay.
iTunes: Yes
iOS: Yes
 # 7 is MythTV version 0.27 as of today
iTunes: Yes
iOS: Yes

Changed 6 months ago by Craig Treleaven <ctreleaven@…>

Changed 6 months ago by Craig Treleaven <ctreleaven@…>

comment:4 Changed 6 months ago by jyavenard

  • Severity changed from medium to low

didn't need the log...

Well, it's obvious then the issue is with the phone and what it enforces and when.

Only bonjour info determines what the iphone shows or not. It's obvious the issue is not consistent.

That you see the "MythTV" device when you use:

# 7:
Terminal 1:

dns-sd -R 5855CA123456@MythTV _raop._tcp local 49152 "da=true" "vs=115.2"
"md=0,1,2" "txtvers=1" "vn=3" "pw=false" "sr=44100" "ss=16" "ch=2"
"cn=0,1" "et=0,1" "ek=1" "sv=false" "sm=false" "tp=UDP"

Terminal 2:

dns-sd -R "MythTV" _airplay._tcp local 7000 "srcvers=115.2"
"model=AppleTV2,1" "features=0xE1B" "deviceid=58:55:CA:12:34:56"

surprised it would show for # 7... Does it disappear each time the dns-sd commands are interrupted and it reappears each time you run them?

if so, does starting myth on that machine makes it appear ? (it uses exactly that info).

In any case, there's nothing more I can do...

comment:5 Changed 3 weeks ago by Jean-Yves Avenard <jyavenard@…>

  • Resolution set to fixed
  • Status changed from new to closed

In 5d2d30bc6af71d06230c6c3d1871dc665d12737c/mythtv:

Fix AirPlay? occasionally only showing as an audio device on iOS 7.x

We re-announce the AirPlay? video service 2s after the first registration followed by every 10s.
This forces the video service to be registered after the RAOP Service. Since the release of iOS 7, AirPlay? has been very much unusable.

Thanks to Memphiz from the XBMC team to figuring the cause.

Fixes #11901

comment:6 Changed 3 weeks ago by Jean-Yves Avenard <jyavenard@…>

In 8ee257cf970c2a304e746524ef43aebe4043331d/mythtv:

Fix AirPlay? occasionally only showing as an audio device on iOS 7.x

We re-announce the AirPlay? video service 2s after the first registration followed by every 10s.
This forces the video service to be registered after the RAOP Service. Since the release of iOS 7, AirPlay? has been very much unusable.

Thanks to Memphiz from the XBMC team to figuring the cause.

Fixes #11901

(cherry picked from commit 5d2d30bc6af71d06230c6c3d1871dc665d12737c)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.