Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11909 closed Bug Report - General (fixed)

AirPlay issues with youtube videos

Reported by: JYA Owned by: JYA
Priority: minor Milestone: 0.27.1
Component: MythTV - Airplay Version: 0.27-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by JYA)

Attempting to watch via AirPlay? a youtube video now fails..

The URL is: http://www.youtube.com/api/manifest/hls_variant/pmbypass/yes/signature/B4C6C29D7C7F39F6D0A14C8FCA341E961B424E16.4ADBF6319A5C8B427F0A7101791208E56F476F96/id/d1a6296c9acfc83a/sparams/id%2Cip%2Cipbits%2Cplaylist_type%2Cpmbypass%2Csource%2Cexpire/source/youtube/sver/3/fexp/907724%2C914504%2C939111%2C915700%2C916611%2C914004%2C924616%2C924610%2C907231/ip/2001%3A470%3A36%3Ab1d%3A4890%3Adb63%3A698a%3Ad38/key/yt1/playlist_type/DVR/upn/wySlwlStqlA/ipbits/0/expire/1381990562/file/index.m3u8?cpn=w6KhEy3g4jF_9Nzw&dnc=1&ibw=701401

that URL doesn't work for long, and they have an expiry.

So to reproduce, start the youtube app on an iPhone, attempt to play: http://www.youtube.com/watch?v=0aYpbJrPyDo

Select using the AirPlay? feature the mythtv frontend: playback on the frontend will fail (See log)

the error comes from MYthDownloadManager failing to download the m3u8 file (though, a separate attempt using Qt QNetworkAccessManager fails just the same)

however, the URL using wget, curl, chrome or even ffplay works just fine

Attachments (4)

wget.pcap (5.6 KB) - added by JYA 6 years ago.
tcpdump capture using wget
frontend.log (68.3 KB) - added by JYA 6 years ago.
frontend log
myth.pcap (3.2 KB) - added by JYA 6 years ago.
tcpdump capture using myth
ringbuffer.diff (2.9 KB) - added by JYA 6 years ago.
small patch to easily test the download using Qt

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by JYA

Attachment: wget.pcap added

tcpdump capture using wget

Changed 6 years ago by JYA

Attachment: frontend.log added

frontend log

comment:1 Changed 6 years ago by JYA

Description: modified (diff)

Changed 6 years ago by JYA

Attachment: myth.pcap added

tcpdump capture using myth

Changed 6 years ago by JYA

Attachment: ringbuffer.diff added

small patch to easily test the download using Qt

comment:2 Changed 6 years ago by Jean-Yves Avenard <jyavenard@…>

Resolution: fixed
Status: newclosed

In cba3bc592f837b4680c2ec8075502b9323bdd3fe/mythtv:

decode URL before attempting to open them.

Thanks to Chris Pinkham for finding the root cause.

Fixes #11909

comment:3 Changed 6 years ago by Jean-Yves Avenard <jyavenard@…>

In 93ada424fc4c307f6408b47aef1912d9d4c07ec9/mythtv:

decode URL before attempting to open them.

Thanks to Chris Pinkham for finding the root cause.

Fixes #11909

(cherry picked from commit cba3bc592f837b4680c2ec8075502b9323bdd3fe)

comment:4 Changed 6 years ago by Raymond Wagner

Milestone: unknown0.27.1
Note: See TracTickets for help on using tickets.