Opened 6 years ago

Closed 6 years ago

#11934 closed Bug Report - General (Works for me)

DB-Table gamemetadata: columns inetref,intid are missing

Reported by: josef@… Owned by:
Priority: minor Milestone: unknown
Component: Plugin - MythGame Version: 0.27-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Nov 3 10:09:46 tv-desktop mythfrontend.real: mythfrontend[29987]: E CoreContext?

mythdbcon.cpp:837 (prepare) Error preparing query: SELECT system,gamename,genre

,year,romname,favorite,rompath,country,crc_value,diskcount,gametype,plot,publish er,version,screenshot,fanart,boxart,inetref,intid FROM gamemetadata WHERE gamena me = :GAMENAME AND system = :SYSTEM ORDER BY diskcount DESC

Attachments (1)

mythfrontend.log.7z (23.4 KB) - added by anonymous 6 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 6 years ago by sphery

Status: newinfoneeded_new

Changed 6 years ago by anonymous

Attachment: mythfrontend.log.7z added

comment:2 Changed 6 years ago by sphery

Resolution: Works for me
Status: infoneeded_newclosed

Your log file has information from 4 different runs of mythfrontend. The error only occurs in the first run, for which logging information is cut off and doesn't show mythfrontend startup (the part that's most important). Since it doesn't occur in the other 3 (and since I'm assuming you tried to reproduce the error with a fresh run, as described in the linked wiki page), I'm going to assume that you're no longer receiving the error and it was only a transient error that occurred due to an improperly updated database schema, which has since been properly updated. (And the code for MythGame? shows that a properly updated database schema will have the columns you were missing.)

If that is not the case and you can still get the error, you'll need to upload a good log file, as described at http://www.mythtv.org/wiki/Posting_Logs, that shows only mythfrontend startup, then your immediately performing the action required to reproduce the error. See, especially, http://www.mythtv.org/wiki/Posting_Logs#Getting_Useful_Logs . Also, feel free to ask questions on the mythtv-users mailing list ( http://www.mythtv.org/mailman/listinfo/mythtv-users ).

Note: See TracTickets for help on using tickets.