Opened 5 years ago

Closed 5 weeks ago

Last modified 5 weeks ago

#11968 closed Patch - Bug Fix (fixed)

Disabling automatic mythfilldatabase still causes wakeups

Reported by: amb@… Owned by: Peter Bennett
Priority: minor Milestone: unknown
Component: MythTV - Scheduling Version: 0.27-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If "Automatically update program listings" (config item MythFillEnabled?) is disabled then the scheduler will still trigger a wakeup time based on the other relevant settings (MythFillSuggestedRunTime? and MythFillGrabberSuggestsTime?).

In version 0.26 this was all within mythbackend/housekeeper.cpp surrounded by a test on MythFillEnabled? but in version 0.27 in mythbackend/scheduler.cpp that test has gone.

The attached patch restores the test on MythFillEnabled?.

The patch also subtracts the StartupSecsBeforeRecording? offset from the recording time and doesn't subtract it from a mythfilldatabase startup time because that looks like unexpected behaviour.

The patch is not tested because that would take another 24 hours and it looks like an obvious fix.

Attachments (1)

mythfill-schedule-fail.diff (1.9 KB) - added by amb@… 5 years ago.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by amb@…

Attachment: mythfill-schedule-fail.diff added

comment:1 Changed 5 years ago by stuartm

Owner: changed from gigem to stuartm
Status: newaccepted

comment:2 Changed 6 weeks ago by Peter Bennett

Owner: changed from stuartm to Peter Bennett
Status: acceptedassigned

comment:3 Changed 5 weeks ago by Peter Bennett <pbennett@…>

Resolution: fixed
Status: assignedclosed

In fb942608d/mythtv:

Scheduler wakeup: Fix inconsistencies with wakeup for mythfilldatabase.

  1. Will not set a wakeup time for mythfilldatabase if "Automatic Update of program listings" is disabled.
  2. Will set a wakeup time for mythfilldatabase even if no programs are scheduled.

Wakeup times for mythfilldatabase are only set when "Run guide data at
time suggested" is enabled.

Fixes #11968
Fixes #13307

comment:4 Changed 5 weeks ago by Peter Bennett <pbennett@…>

In fb942608d/mythtv:

Scheduler wakeup: Fix inconsistencies with wakeup for mythfilldatabase.

  1. Will not set a wakeup time for mythfilldatabase if "Automatic Update of program listings" is disabled.
  2. Will set a wakeup time for mythfilldatabase even if no programs are scheduled.

Wakeup times for mythfilldatabase are only set when "Run guide data at
time suggested" is enabled.

Fixes #11968
Fixes #13307

comment:5 Changed 5 weeks ago by Peter Bennett <pbennett@…>

In fb942608d/mythtv:

Scheduler wakeup: Fix inconsistencies with wakeup for mythfilldatabase.

  1. Will not set a wakeup time for mythfilldatabase if "Automatic Update of program listings" is disabled.
  2. Will set a wakeup time for mythfilldatabase even if no programs are scheduled.

Wakeup times for mythfilldatabase are only set when "Run guide data at
time suggested" is enabled.

Fixes #11968
Fixes #13307

Note: See TracTickets for help on using tickets.