Opened 14 years ago

Closed 14 years ago

#1197 closed defect (invalid)

LiveTV decoder not working (svn versions 8798 and up)

Reported by: stuart@… Owned by: Isaac Richards
Priority: critical Milestone: unknown
Component: mythtv Version:
Severity: high Keywords:
Cc: Ticket locked: no

Description (last modified by danielk)

Im not sure where to start looking for this one but it happens on every channel and every decoder

system is dual xeon asus pch-dl mobo 1 gb ram 5 x sata nvidia 7676 drivers x 4.5.0 kernel 2.6.15.2 blfs build 6.1 gcc 4.0.2

<LOG> 2006-02-02 15:57:30.640 Connecting to backend server: 192.168.2.10:6543 (try 1 of 5) 2006-02-02 15:57:30.656 Using protocol version 26 2006-02-02 15:57:30.695 TV: Attempting to change from None to WatchingLiveTV 2006-02-02 15:57:30.715 Using protocol version 26 0: start_time: -9223372036854.775 duration: -9223372036854.775 stream: start_time: -9223372036854.775 duration: -9223372036854.775 bitrate=0 kb/s 2006-02-02 15:57:31.797 AFD: Opened codec 0x826ec00, id(MPEG2VIDEO_XVMC) type(Video) 2006-02-02 15:57:31.797 NVP: Disabling Audio, params(-1,-1,-1) 2006-02-02 15:57:31.797 NVP: Disabling Audio, params(0,-1,-1) X Error: BadMatch? (invalid parameter attributes) 8

Major opcode: 141 Minor opcode: 14 Resource id: 0x182

2006-02-02 15:57:31.824 VideoOutputXv? Error: Couldn't get the color key color,

probably due to a driver bug or limitation. You might not get any video, but we'll try anyway.

GetModeLine? - scrn: 0 clock: 94500 GetModeLine? - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376

vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 5

GetModeLine? - scrn: 0 clock: 94500 GetModeLine? - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376

vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 5

2006-02-02 15:57:32.189 New DB connection, total: 3 2006-02-02 15:57:32.189 Using realtime priority. 2006-02-02 15:57:32.190 Connected to database 'mythconverg' at host: 192.168.2.10 2006-02-02 15:57:32.206 TV: Changing from None to WatchingLiveTV 2006-02-02 15:57:32.343 Video timing method: SGI OpenGL 2006-02-02 15:57:33.177 AFD Error: Could not find codec parameters. file was "/mnt/store/myth/recordings/1004_20060202155731.mpg". 2006-02-02 15:57:33.178 Couldn't open decoder for: /mnt/store/myth/recordings/1004_20060202155731.mpg 2006-02-02 15:57:33.178 NVP, Error: Unknown error, exiting decoder </LOG>

Any help appreciated

Change History (7)

comment:1 Changed 14 years ago by cca@…

I get the same problem here with nvidia 8178 drivers and gcc 4.1.0 (x86_64). It does not matter which decoder I use. If I record, it will playback and then I can watch LiveTV for a while. It will then unpredictably go back to "AFD Error: Could not find codec parameters" during a restart. I don't know what triggers the change. Stuart: can you also record and playback?

comment:2 Changed 14 years ago by anonymous

Exactly the same, when I enter LiveTV the backend starts recording as normal and I can later watch the recording. I never get any LiveTV on the frontend tho.

Scheduled recordings/playback also work normally.

I was wondering if LiveTV was reading the buffer file before the backend had streamed any data into it, hence the "no decoder" error.

Stuart

comment:3 Changed 14 years ago by anonymous

I just did a bit of experimentation! When I can get LiveTV working, I can restart mythtv many times with no problem. However, if I change to another channel and then exit mythtv, when I restart I get the above error. Also, mythtv does not exit after the error:

VideoOutputXv?: Closing XVideo port 274

LiveTVChain(live-...-2006-02-02T16:38:08): ReloadAll?(): Added new recording

and it sits like that until killed. The problem then persists unless I schedule and record another program.

comment:4 Changed 14 years ago by anonymous

What log level are you using? I dont see that error.

Symptoms are the same tho

comment:5 Changed 14 years ago by cca@…

Sorry, my mistake. That error only appears sometimes and after a long delay, and if it does, I can watch LiveTV again afterwards!

comment:6 Changed 14 years ago by cca@…

In mythweb, all the LiveTV recordings are listed as 'currently recording' and even if I delete them all there are residual .mpg files in my /mnt/store directory. If I delete those files I can watch LiveTV again.

comment:7 Changed 14 years ago by danielk

Description: modified (diff)
Resolution: invalid
Status: newclosed

This is not a discussion forum. Please use the mailing lists. Everytime you post to trac, everyone on the CVS mailing list gets an unthreaded e-mail.

Besides this ticket looks like a duplicate of several tickets, and doesn't have the information required to reproduce the problem.

Note: See TracTickets for help on using tickets.