Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12036 closed Bug Report - General (fixed)

Only 1 network recorder works

Reported by: Jeremy Seibel <supaseibz@…> Owned by: Stefan Becker <chemobejk@…>
Priority: minor Milestone: 0.27.1
Component: MythTV - Recording Version: 0.27-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

mythtv install with 2 network recorders. The first recorder will work fine, any additional network recorders wont capture the stream/write the file to disk. No apparent errors in backend logs. wireshark shows multicast join, and channel stream data.

Attachments (1)

mythbackend.log (32.0 KB) - added by Jeremy Seibel <supaseibz@…> 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Jeremy Seibel <supaseibz@…>

Attachment: mythbackend.log added

comment:1 Changed 6 years ago by Karl Egly

Milestone: 0.27.1unknown

Possible duplicate of #11979, can you test the patch from that ticket?

comment:2 Changed 6 years ago by Jeremy Seibel <supaseibz@…>

confirmed, the above patch fixes the issue.

Sorry for the duplicate, must have missed it when searching.

comment:3 Changed 6 years ago by Stefan Becker <chemobejk@…>

Owner: set to Stefan Becker <chemobejk@…>
Resolution: fixed
Status: newclosed

In f2defe87d63fbe544c7333af0ca5b04aa078ebf4/mythtv:

Bind to multicast address instead of ANY

If multiple servers multicast content on the same port we can't receive
it on multiple recorders if bind to QHostAddress::Any. If we bind to the
multicast address we don't have this problem. Problem discovered and
patched by Niels Ole Kirkeby.

Note: This also adds error handling for when a bind fails.

Fixes #11979
Fixes #12036

The tickets contain multiple reports of success.

comment:4 Changed 6 years ago by Stefan Becker <chemobejk@…>

In b249ad4d241b8a3adf7b3cde8a26b03e736febd2/mythtv:

Bind to multicast address instead of ANY

If multiple servers multicast content on the same port we can't receive
it on multiple recorders if bind to QHostAddress::Any. If we bind to the
multicast address we don't have this problem. Problem discovered and
patched by Niels Ole Kirkeby.

Note: This also adds error handling for when a bind fails.

Fixes #11979
Fixes #12036

The tickets contain multiple reports of success.
(cherry picked from commit f2defe87d63fbe544c7333af0ca5b04aa078ebf4)

comment:5 Changed 6 years ago by Raymond Wagner

Milestone: unknown0.27.1
Note: See TracTickets for help on using tickets.