Opened 13 years ago

Closed 13 years ago

#1205 closed defect (duplicate)

Recording one episode that is followed by another will corrupt tv listing

Reported by: jyavenard@… Owned by: Isaac Richards
Priority: minor Milestone: 0.19
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Summmary: If you try to record one TV program that is followed by another one with the same name, it will then become impossible to record the program following (different episode, of the same series)

Example: today there was two episodes of "Charmed" playing in a row. There was one episode going from 8:30PM to 9:25PM and the other from 9:25PM to 10:20PM

In mythweb, in TV Listing I clicked on the first episode and selected "Record only this showing" and validated. Went back into TV listing, the second episode of charmed was gone from the list and the first one was now filling the timeslot 8:30PM to 10:20PM

On clicking on this episode again, in the summary of the recording it said: "Fri, Feb 3 (Rerun) 08:30:00 PM to 10:20:00 PM (55 mins) As you can see, while it showed the timing to go from 8:30PM to 10:20PM, the length wasn't correct (55 minutes instead of what should be 110 minutes) Going into the backend status page, it showed that the encoder 1 was recording "" and that it would end at 9:20PM.

From there I went back into the TV Listing, and the two episodes listing were gone...

I have reproduced it three times already, as soon as you record one episode that is followed by another, the 2nd episode will disappear from the TV listing

Change History (1)

comment:1 Changed 13 years ago by Dibblah

Resolution: duplicate
Status: newclosed

Duplicate of #1202

Please read the original comments on the ticket. It's impossible for the devs to diagnose a crashing issue without a backtrace, the instructions for which are in the documentation.

Note: See TracTickets for help on using tickets.