Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12088 closed Bug Report - General (fixed)

Audio CD playback: can only play the first track

Reported by: amlopezalonso@… Owned by: paulh
Priority: minor Milestone: 0.28
Component: Plugin - MythMusic Version: Master Head
Severity: medium Keywords: audio CD, first track
Cc: Ticket locked: no

Description

Mythmusic seems to play only the first track of an audio CD. I can select other tracks to play and so it appears in the OSD, but the audio always belongs to the first track in the CD.

I will provide log reports under specific request as I do not know which flags to include.

Regards, Antonio

Change History (3)

comment:1 Changed 6 years ago by Paul Harrison <pharrison@…>

Owner: set to Paul Harrison <pharrison@…>
Resolution: fixed
Status: newclosed

In 2e009edb4f99a575cd6be5567166ca0787db40c5/mythtv:

MythMusic: fix playback from CD only playing the first track

We already get the filename passed in the ctor so don't try to get it from
the input. Fixes #12088.

comment:2 Changed 6 years ago by paulh

Milestone: unknown0.28
Owner: changed from Paul Harrison <pharrison@…> to paulh

comment:3 Changed 6 years ago by Paul Harrison <pharrison@…>

In cffec7f607d550b1cf51a75315104559732ca343/mythtv:

MusicMetadata?: copy m_actualFilename in operator=

This fixes the regression that was the root cause of #12088 and also a similar
problem in the import screen when trying to play the tracks there as well.

Refs #12088.

Note: See TracTickets for help on using tickets.