Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#12090 closed Patch - Feature (fixed)

Services API - Get cut list and comm break for recorded

Reported by: jlbarriere68@… Owned by: janbar <jlbarriere68@…>
Priority: minor Milestone: 0.28
Component: MythTV - Services API - Backend Version: Master Head
Severity: medium Keywords: COMM BREAK, EDL, CUT LIST
Cc: Ticket locked: no

Description

This is a patch adding the ability to get cut list and comm break for recordings. Also new servives are able to return offset by keyframe, position or duration depending of request parameter "OffsetType?" { nil , "Position", "Duration" }

I made a PR to github: https://github.com/MythTV/mythtv/pull/70

Change History (7)

comment:1 Changed 6 years ago by sphery

Milestone: 0.28unknown

Overlaps with/partial duplicate of #11491. We'll have to decide on a single approach.

comment:2 Changed 5 years ago by Drew <drew@…>

It would be nice to see this or #11491 implemented soon. It restricts proper commercial skips and EDL use on videos that don't have a steady framerate.

The Services API would obviously be better, but those patches aren't for version 0.28. If those get modified to go into the 0.28 tree, could it get submitted?

comment:3 Changed 5 years ago by jlbarriere68@…

I can rebase soon the code to be merged again into master.

comment:4 Changed 5 years ago by jlbarriere68@…

I rebased my PR from github on the last commit of master of mythtv.

comment:5 Changed 5 years ago by janbar <jlbarriere68@…>

Owner: set to janbar <jlbarriere68@…>
Resolution: fixed
Status: newclosed

In 3182179254c97b6cff7a000b9ebfa304c2a66a61/mythtv:

Services API - Get cut list and comm break for recorded

This is a patch adding the ability to get cut list and comm break for recordings.
Also new services are able to return offset by keyframe, position or duration
depending of request parameter "OffsetType?" { nil , "Position", "Duration" }

Closes #12090

Signed-off-by: Stuart Morgan <smorgan@…>

comment:6 Changed 5 years ago by janbar <jlbarriere68@…>

In cedd7a4d99110792ae20cbbc3d6cb64c25fcf56f/mythtv:

Use RecordingInfo? instead ProgramInfo? as recommended

Refs #12090

Signed-off-by: Stuart Morgan <smorgan@…>

comment:7 Changed 4 years ago by Karl Egly

Milestone: unknown0.28
Note: See TracTickets for help on using tickets.