Opened 5 years ago

Closed 5 years ago

#12119 closed Bug Report - General (Won't Fix)

MythMediaStream Redux - Watch Recordings - Text description not updating

Reported by: rotak@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This is about version 28.1 of MythMediaStream? Redux.

When I switch to the watch recordings screen and scroll through the recordings, I can see the top left symbols and the picture is being updated, but the whole text section under the picture (title, description, etc) always shows the info of the first entry.

I can make it update if I press "I" to see the detailed info and hit ESC afterwards. Then it would update the text to match the recording I've selected.

I could reproduce this bug on two remote frontends (master backend wasn't updated to 28.1 after I found this). All boxes are running the latest 0.27+fixes.

Change History (5)

comment:1 Changed 5 years ago by Raymond Wagner

Resolution: Need more Info
Status: newclosed
Version: UnspecifiedMaster Head

Can you reproduce this issue in either of the packaged themes? It sounds like this is just an issue of something in the developmental UI code changing, and a 3rd party theme has not yet been updated to handle it.

comment:2 Changed 5 years ago by Raymond Wagner

Resolution: Need more Info
Status: closednew

comment:3 Changed 5 years ago by Raymond Wagner

Status: newinfoneeded_new

comment:4 Changed 5 years ago by rotak@…

Well, I don't know if the mythbuntu DEBs are any different from the "normal" mythtv distrubution. At the end, I'll add a list of installed packages.

The update of the theme was announced when I started the frontend, so I updated using the theme manager. Also, the theme is in the list by default. Don't know if it's a 3rd party theme.

However, I found a workaround. Using openGL instead of QT fixes all issues. I don't know if this makes the bug "invalid".

ii  libmyth-0.27-0                               2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 Common library code for MythTV and add-on modules (runtime)
ii  libmyth-python                               2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 A python library to access some MythTV features
ii  libmythtv-perl                               2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 A PERL library to access some MythTV features
ii  mythbuntu-bare-client                        2.5                                                Mythbuntu Bare Client
ii  mythbuntu-common                             0.67                                               Mythbuntu application support functions
ii  mythbuntu-control-centre                     0.63-0ubuntu2                                      Mythbuntu Configuration Application
ii  mythbuntu-default-settings                   1.08                                               default settings for Mythbuntu
ii  mythbuntu-desktop                            0.77                                               The Mythbuntu standalone system
ii  mythbuntu-lightdm-theme                      1.01                                               Mythbuntu LightDM setup
ii  mythbuntu-log-grabber                        0.10-0ubuntu2                                      Mythbuntu diagnostic utility
ii  mythgallery                                  2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 Image gallery/slideshow add-on module for MythTV
ii  mythmusic                                    2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 Music add-on module for MythTV
ii  mythtv                                       2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 Personal video recorder application (client and server)
ii  mythtv-backend                               2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 Personal video recorder application (server)
ii  mythtv-backend-master                        2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 Metapackage to setup and configure a "Master Backend" profile of MythTV.
ii  mythtv-common                                2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 Personal video recorder application (common data)
ii  mythtv-database                              2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 Personal video recorder application (database)
ii  mythtv-dbg                                   2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 Debug symbols for mythtv packages
ii  mythtv-frontend                              2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 Personal video recorder application (client)
ii  mythtv-theme-mythbuntu                       2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 The mythbuntu MythTV Theme
ii  mythtv-transcode-utils                       2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 Utilities used for transcoding MythTV tasks
ii  mythweb                                      2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 Web interface add-on module for MythTV
ii  php-mythtv                                   2:0.27.0+fixes.20140411.ad2f1ff-0ubuntu0mythbuntu2 PHP Bindings for MythTV

comment:5 Changed 5 years ago by paulh

Resolution: Won't Fix
Status: infoneeded_newclosed

This is a know bug that only affects the QT painter which is caused by the group widget not resizing properly to the biggest child widget.

Unfortunately fixing this bug would break several themes that use negative coordinates to position widgets so we are stuck with what we have for now.

The easy fix is to ensure any group widget has an area big enough to cover all it's children.

Note: See TracTickets for help on using tickets.