Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#12128 closed Bug Report - General (fixed)

"Add ReadInternalMode to RingBuffer class" commit breaks editing

Reported by: gnassas@… Owned by: Jean-Yves Avenard <jyavenard@…>
Priority: minor Milestone: 0.27.2
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I recently updated from late March master to recent (April 26) and editing stopped working for me.

The symptom is the frame display no longer updates when you move around the recording. The frame and position numbers change but the frame stays the same. When you exit the edit you get the end of recording "keep/delete" dialog as if you were at the end of the recording even if you aren't.

A bisect pointed the finger at the recent RingBuffer? changes. The bisect output was:

c519bba367320a3773c093c30d05e1330534589c is the first bad commit
commit c519bba367320a3773c093c30d05e1330534589c
Author: Jean-Yves Avenard <jyavenard@mythtv.org>
Date:   Sat Apr 26 17:31:36 2014 +1000

    Add ReadInternalMode to RingBuffer class
    
    This mode allows to limit the content of the ringbuffer to the content already loaded. Seeking, reading and other operations will not be destructive.
    This allows for almost instantaneous streams and bitrate detection.
    
    Duration calculated will obviously be wrong, but as the duration is stored in the DB we’ll use that duration instead anyway, meaning we only have to worry about streams detection itself.
    
    This greatly speed up liveTV transition change and playback startup

:040000 040000 f7bc65ad6761416b61127aa9e987058f0e8463c3 2cbb58487e13b39b373b08b006762ad33930e206 M	mythtv

Change History (10)

comment:1 Changed 6 years ago by JYA

can't reproduce it here...

As mentioned earlier it is *impossible* for this change to have an effect for video editing, as the code is only active during live TV , right at the start of live TV (when the stream is opened)

comment:2 Changed 6 years ago by JYA

actually, was using the devel/027candidates branch which has all my last changes to the ringbuffer..

I can reproduce it in master, even going back to end of february....

tracking...

I wonder if this issue is similar to the one causing an old frame to appear from time to time when we switch channel

comment:3 Changed 6 years ago by JYA

very weird...

Running a master frontend against a 0.27 backend/0.27 database issue can't be reproduced

0.27 frontend -> 0.27 backend : ok

0.27 fronted -> 0.27 backend with master database: no okay

comment:4 Changed 6 years ago by JYA

If you revert e46904385382ca90f71ae472e88bd3dcd6cf1d7f and c519bba367320a3773c093c30d05e1330534589c (in that order) you're saying you don't have the problem?

comment:5 Changed 6 years ago by JYA

I reverted to an older database backup from a few days ago, and again I can't reproduce the issue despite trying for the past 3 hours.

Closing this bug as it's obviously related to something that was done in the database but can't figured what

comment:6 Changed 6 years ago by JYA

Resolution: Works for me
Status: newclosed

comment:7 Changed 6 years ago by JYA

Resolution: Works for me
Status: closednew

it does introduce a regression...

apologies

comment:8 Changed 6 years ago by Jean-Yves Avenard <jyavenard@…>

Owner: set to Jean-Yves Avenard <jyavenard@…>
Resolution: fixed
Status: newclosed

comment:9 Changed 6 years ago by Jean-Yves Avenard <jyavenard@…>

comment:10 Changed 5 years ago by paulh

Milestone: unknown0.27.2
Note: See TracTickets for help on using tickets.